链接:

http://poj.org/problem?id=3080

http://acm.hust.edu.cn/vjudge/contest/view.action?cid=88230#problem/E    (密码0817)

 

Blue Jeans
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14544   Accepted: 6478

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

 

第一次接触 KMP 算法, 看了一下不是很懂, 感觉是解决字符串匹配的问题,不知道理解是否正确,先粘个代码学习一下

 

这个就是个暴力加KMP, 子串的长度要大于等于3,相同长度的要字典序最大的

 

代码:

#include<stdio.h>
#include<string.h>

#define N 100

char s[N][N];
int next[N];

void GetNext(char s[])
{
    int i=0, j=-1, n=strlen(s);
    next[0] = -1;

    while(i<n)
    {
        if(j==-1 || s[i]==s[j])
            next[++i] = ++j;
        else
            j = next[j];
    }
}
bool KMP(char a[], char s[])
{
    int i=0, j=0;
    int Na=strlen(a), Ns=strlen(s);

    while(i<Na)
    {
        while(j==-1 || (a[i]==s[j] && i<Na))
            i++, j++;

        if(j==Ns) return true;

        j = next[j];
    }
    return false;
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int i, j, len, m, MaxLen = 60;
        char ans[N]="Z";

        scanf("%d", &m);

        for(i=0; i<m; i++)
            scanf("%s", s[i]);

        for(len=60; len>=3; len--)
        for(i=0; i<=MaxLen-len; i++) ///枚举第一个串的所有子串
        {
            char b[N]={0};

            strncpy(b, s[0]+i, len);
            GetNext(b);

            for(j=1; j<m; j++)
                if(KMP(s[j], b)==false)
                    break;

            if(j==m && strcmp(ans, b)>0)
                strcpy(ans, b);

            if(ans[0]!='Z' && i==MaxLen-len)
                i=100, len=0; ///跳出循环
        }

        if(ans[0] == 'Z')
            printf("no significant commonalities\n");
        else
            printf("%s\n", ans);
    }
    return 0;
}

 

posted on 2015-08-18 19:53  栀蓝  阅读(179)  评论(0编辑  收藏  举报

levels of contents