欢迎来到PJCK的博客

(数字三角形)POJ1163 The Triangle

The Triangle
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 59698   Accepted: 35792

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

DP水题,记忆化递归和递推都行,其状态转换式为 dp[i][j] = a[i][j] + max{d[i+1][j],d[i+1][j+1]};

C++代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 102;
int a[maxn][maxn];
int dp[maxn][maxn];
int main(){
    int N;
    scanf("%d",&N);
    memset(a,0,sizeof(a));
    for(int i = 1; i <= N; i++){
        for(int j = 1; j <= i; j++)
            cin>>a[i][j];
    }
    memset(dp,-1,sizeof(dp));
    for(int i = 1; i <= N; i++)
        dp[N][i] = a[N][i];
    for(int i = N-1; i >= 1;i--){
        for(int j = 1; j <= i; j++)
            dp[i][j] = max(dp[i+1][j],dp[i+1][j+1]) + a[i][j];
    }
    printf("%d\n",dp[1][1]);
    return 0;
}

 

posted @ 2019-03-12 13:17  PJCK  阅读(147)  评论(0编辑  收藏  举报