//目录

Poj(1273),最大流,EK

Drainage Ditches
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 69355   Accepted: 26873

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source

 
题意:现在有m个池塘(从1到m开始编号,1为源点,m为汇点),及n条水渠,给出这n条水渠所连接的池塘和所能流过的水量,求水渠中所能流过的水的最大容量.一道基础的最大流题目。
分析:嗯,这里有判重,两个点之间有多条边。不看模板已经可以做了。
#include <bits/stdc++.h>

using namespace std;

#define INF 0x3f3f3f3f

int cap[300][300];
int flow[300][300];
int pre[300];

int main()
{
    //freopen("input.txt","r",stdin);
    int n,m;

    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(cap,0,sizeof(cap));
        for(int i=0; i<m; i++)
        {
            int a,b,value;
            scanf("%d%d%d",&a,&b,&value);
            cap[a][b] += value;
        }

        memset(flow,0,sizeof(flow));
        queue<int> Q;

        int node[300];
        int ans = 0;
        while(true)
        {
            Q.push(1);
            memset(node,0,sizeof(node));
            node[1] = INF;
            int u;
            while(!Q.empty())
            {
                u = Q.front();
                Q.pop();
                for(int i=1; i<=n; i++)
                {
                    if(!node[i]&&cap[u][i]>flow[u][i])
                    {
                        Q.push(i);
                        node[i] = min(node[u],cap[u][i]-flow[u][i]);
                        pre[i] = u;
                    }
                }
            }
            if(node[n]==0)
                break;

            for(u = n; u!=1; u=pre[u])
            {
                flow[pre[u]][u] +=node[n];
                flow[u][pre[u]] -=node[n];
            }
            ans+=node[n];
        }

        printf("%d\n",ans);
    }
    return 0;
}

 

posted @ 2016-08-09 14:11  小草的大树梦  阅读(206)  评论(0编辑  收藏  举报