pat 1070. Mooncake (25)

1070. Mooncake (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:
3 200
180 150 100
7.5 7.2 4.5
Sample Output:
9.45

解:贪心法,一般背包问题。

代码:

//很简单的一般背包问题
#include<iostream>
#include<cstdlib>
#include<cstdio>
using namespace std;

struct mooncake
{
    double amount;
    double price;
    double v;
};
int main()
{
    int n,m;
    while(cin>>n) //n表示mooncake种类数
    {
        cin>>m;  //m表示amount总量
        mooncake *mo=new mooncake[n+1];
        double sum=0; //计算最大利润值
        for(int i=0;i<n;i++)
        {
            cin>>mo[i].amount;
        }
        for(int i=0;i<n;i++)
        {
            cin>>mo[i].price;
            mo[i].v=mo[i].price/mo[i].amount;
        }
        //排序
        for(int i=0;i<n;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                if(mo[i].v<mo[j].v)
                {
                    mooncake temp=mo[i];
                    mo[i]=mo[j];
                    mo[j]=temp;
                }
            }
        }
        int i;
        for(i=0;i<n;i++)
        {
            if(mo[i].amount<=m)
            {
                sum+=mo[i].price;
                m-=mo[i].amount;
            }
            else
                break;
        }
        if(i<n&&m>0)
            sum+=m*1.0/mo[i].amount*mo[i].price;
       printf("%.2lf\n",sum);
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

posted on 2015-07-19 11:21  Tob__yuhong  阅读(170)  评论(0编辑  收藏  举报

导航