pat 1041. Be Unique (20)

1041. Be Unique (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None
解:开大数组,还好没卡内存,平稳渡劫。我觉得最关键的点在if(a[b[i]]==1)这里,这里b[i]保证是按照输入值的顺序进行判断的。还有一点值得注意的是:每次while循环时要将整个a数组置零。

代码:

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
    int n;
    int a[100000+1];
    while(cin>>n)
    {
        int temp;
        memset(a,0,sizeof(a));
        int *b=new int[n+1];
        for(int i=0;i<n;i++)
        {
            cin>>temp;
            b[i]=temp;
            a[temp]++;
        }
        int tob=0;
        for(int i=0;i<n;i++)
        {
            if(a[b[i]]==1)
            {
                tob=1;
                cout<<b[i]<<endl;
                break;
            }
        }
        if(tob==0)
            cout<<"None"<<endl;
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

posted on 2015-07-19 16:51  Tob__yuhong  阅读(126)  评论(0编辑  收藏  举报

导航