Tinamei
其实你不知道你不知道

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 223    Accepted Submission(s): 151


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

 

Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n, denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi, describe the coordinates of n stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

 

Sample Input
3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0
 

 

Sample Output
NO
YES
NO
 

 

Source
 题意:给你n个整数点,问这n个点能否组成正多边形。因为都是整数点,所以组成的正多边形只能是正方形。所以只需判断是否为正方形就好啦
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>

using namespace std;

#define N 25

int n;

struct node
{
    int x, y;
}P[N];

int slove(int i, int j, int k, int q)   // 判断是否为正四边形
{
    if(i == j || i == k)   // 不能有重点
        return false;
    if(i == q || j == k)
        return false;
    if(j == q || k == q)
        return false;

    int w = 0, num[8];
    memset(num, 0, sizeof(num));

    num[w++] = (P[i].x-P[j].x)*(P[i].x-P[j].x)+(P[i].y-P[j].y)*(P[i].y-P[j].y);
    num[w++] = (P[i].x-P[k].x)*(P[i].x-P[k].x)+(P[i].y-P[k].y)*(P[i].y-P[k].y);
    num[w++] = (P[i].x-P[q].x)*(P[i].x-P[q].x)+(P[i].y-P[q].y)*(P[i].y-P[q].y);
    num[w++] = (P[j].x-P[k].x)*(P[j].x-P[k].x)+(P[j].y-P[k].y)*(P[j].y-P[k].y);
    num[w++] = (P[j].x-P[q].x)*(P[j].x-P[q].x)+(P[j].y-P[q].y)*(P[j].y-P[q].y);
    num[w++] = (P[q].x-P[k].x)*(P[q].x-P[k].x)+(P[q].y-P[k].y)*(P[q].y-P[k].y);

    sort(num, num+w);

    w = unique(num, num+w) - num;

    if(w != 2)     // 只能有两种不相同的边
        return false;
    return true;
}

int main()
{
    int t;
    scanf("%d\n", &t);
    while(t--)
    {
        scanf("%d", &n);

        int ans = 0;

        for(int i = 1; i <= n; i++)
            scanf("%d%d", &P[i].x, &P[i].y);
        if(n != 4)
        {
            printf("NO\n");
            continue;
        }

        for(int i = 1; i <= n; i++)
            for(int j = i+1; j <= n; j++)
                for(int k = j+1; k <= n; k++)
                    for(int q = k+1; q <= n; q++)
                        if(slove(i, j, k, q))
                            ans++;
        if(ans != 0)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

  

posted on 2015-11-07 13:15  Tinamei  阅读(176)  评论(0编辑  收藏  举报