Tinamei
其实你不知道你不知道

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 430    Accepted Submission(s): 196


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,,an, is it almost sorted?
 

 

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1,a2,,an.

1T2000
2n105
1ai105
There are at most 20 test cases with n>1000.
 

 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

 

Sample Input
3
 
 
3
2 1 7
 
3
3 2 1
 
5
3 1 4 1 5
 

 

Sample Output
YES
YES
NO
题意: 定义一数组类型为almost sorted,满足在数组中最多存在一个数,删除后数组满足非递增或非递减。
 
#include<iostream>
#include<cstdio>

using namespace std;

#define maxn 100005
#define INF 0x3f3f3f3f

int a[maxn], n;

bool stobig()   // 判断该数组变成 非递减数组是否只需要删除一个数
{
    int sum = 0;
    a[0] = -INF, a[n+1] = INF;
    for(int i = 1; i <= n; i++)
    {
        if(a[i-1] > a[i])
        {
            if(sum == 1)
                return false;
            sum++;
            if( a[i-1] > a[i+1] && a[i] < a[i-2] )
                return false;
        }
    }
    return true;
}

bool btosmall()   // 判断该数组变成 非递增数组是否只需要删除一个数
{
    int sum = 0;
    a[0] = INF, a[n+1] = -INF;
    for(int i = 1; i <= n; i++)
    {
        if(a[i] < a[i+1])
        {
            if(sum == 1)
                return false;
            sum++;
            if( a[i-1] < a[i+1] && a[i+2] > a[i] )
                return false;
        }
    }
    return true;
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
        }
        if(stobig() || btosmall())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

  

posted on 2015-11-04 19:50  Tinamei  阅读(295)  评论(0编辑  收藏  举报