hdu 3642 Get The Treasury

Get The Treasury

http://acm.hdu.edu.cn/showproblem.php?pid=3642

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Jack knows that there is a great underground treasury in a secret region. And he has a special device that can be used to detect treasury under the surface of the earth. One day he got outside with the device to ascertain the treasury. He chose many different locations on the surface of the earth near the secret region. And at each spot he used the device to detect treasury and got some data from it representing a region, which may contain treasury below the surface. The data from the device at each spot is six integers x1, y1, z1, x2, y2 and z2 (x1<x2, y1<y2, z1<z2). According to the instruction of the device they represent the range of x, y and z coordinates of the region. That is to say, the x coordinate of the region, which may contain treasury, ranges from x1 to x2. So do y and z coordinates. The origin of the coordinates is a fixed point under the ground.
Jack can’t get the total volume of the treasury because these regions don’t always contain treasury. Through years of experience, he discovers that if a region is detected that may have treasury at more than two different spots, the region really exist treasure. And now Jack only wants to know the minimum volume of the treasury.
Now Jack entrusts the problem to you.

 

 

Input
The first line of the input file contains a single integer t, the number of test cases, followed by the input data for each test case.
Each test case is given in some lines. In the first line there is an integer n (1 ≤ n ≤ 1000), the number of spots on the surface of the earth that he had detected. Then n lines follow, every line contains six integers x1, y1, z1, x2, y2 and z2, separated by a space. The absolute value of x and y coordinates of the vertices is no more than 106, and that of z coordinate is no more than 500.

 

 

Output
For each test case, you should output “Case a: b” in a single line. a is the case number, and b is the minimum volume of treasury. The case number is counted from one.
 

 

Sample Input
2 1 0 0 0 5 6 4 3 0 0 0 5 5 5 3 3 3 9 10 11 3 3 3 13 20 45
 

 

Sample Output
Case 1: 0 Case 2: 8
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2871 3308 3641 3397 1540 
 
题意:求n个长方体至少相交3次的体积和
z这一维只有500,所以枚举z轴,然后就相当于二维的扫描线
线段树维护区间完全覆盖1、2、3次的长度
 
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
#define N 1001
#define lc k<<1,l,mid
#define rc k<<1|1,mid+1,r
struct node
{
    int l,r,h,f;
    bool operator < (node p)const
    {
        return h<p.h;
    }
}a[N<<1];
struct edge
{
    int x,xx,y,yy,z,zz;
}b[N];
int sum1[N<<3],sum2[N<<3],sum3[N<<3],f[N<<3],has[N<<1],has2[N<<1];
long long ans;
int n,cnt,opl,opr,w; 
void up(int k,int l,int r)
{
    if(f[k]>=3) sum3[k]=has2[r+1]-has2[l];
    else if(f[k]==2)
    {
        sum3[k]=sum1[k<<1]+sum1[k<<1|1];
        sum2[k]=has2[r+1]-has2[l];
    }
    else if(f[k]==1)
    {
        sum3[k]=sum2[k<<1]+sum2[k<<1|1];
        sum2[k]=sum1[k<<1]+sum1[k<<1|1];
        sum1[k]=has2[r+1]-has2[l];
    }
    else
    {
        sum3[k]=sum3[k<<1]+sum3[k<<1|1];
        sum2[k]=sum2[k<<1]+sum2[k<<1|1];
        sum1[k]=sum1[k<<1]+sum1[k<<1|1];
    }
}
void change(int k,int l,int r)
{
    if(opl<=l && r<=opr)
    {
        f[k]+=w;
        up(k,l,r);
        return;
    }
    int mid=l+r>>1;
    if(opl<=mid) change(lc);
    if(opr>mid) change(rc);
    up(k,l,r); 
}
int main()
{
    int T;
    scanf("%d",&T);
    for(int t=1;t<=T;t++)
    {
        ans=0;
        cnt=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++) 
        {
            scanf("%d%d%d%d%d%d",&b[i].x,&b[i].y,&b[i].z,&b[i].xx,&b[i].yy,&b[i].zz);
            has[i*2-1]=b[i].z; has[i*2]=b[i].zz;
        }
        sort(has+1,has+2*n+1);
        cnt=unique(has+1,has+2*n+1)-(has+1);
        for(int i=1;i<cnt;i++)
        {
            int sz=0;
            for(int j=1;j<=n;j++)
             if(b[j].z<=has[i] && b[j].zz>=has[i+1])
             {
                 a[++sz].l=b[j].x; a[sz].r=b[j].xx; a[sz].h=b[j].y; a[sz].f=1;
                 a[++sz].l=b[j].x; a[sz].r=b[j].xx; a[sz].h=b[j].yy; a[sz].f=-1;
                 has2[sz-1]=b[j].x; has2[sz]=b[j].xx;
             }
            sort(has2+1,has2+sz+1);
            int m=unique(has2+1,has2+sz+1)-(has2+1);
            sort(a+1,a+sz+1);
            memset(sum1,0,sizeof(sum1));
            memset(sum2,0,sizeof(sum2));
            memset(sum3,0,sizeof(sum3));
            for(int j=1;j<=sz;j++)
            {
                opl=lower_bound(has2+1,has2+m+1,a[j].l)-has2;
                opr=lower_bound(has2+1,has2+m+1,a[j].r)-has2-1;
                w=a[j].f;
                change(1,1,m);
                ans+=1ll*sum3[1]*(a[j+1].h-a[j].h)*(has[i+1]-has[i]);
            }
        }
        printf("Case %d: %I64d\n",t,ans);
    }
}

 

 
posted @ 2017-07-09 16:53  TRTTG  阅读(312)  评论(0编辑  收藏  举报