poj1207 3n+1 problem

The 3n + 1 problem
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 60496   Accepted: 19218

Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs. 
Consider the following algorithm: 


1. input n

2. print n

3. if n = 1 then STOP

4. if n is odd then n <-- 3n+1

5. else n <-- n/2

6. GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 


Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0. 

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j. 

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

Source

[Submit]   [Go Back]   [Status]   [Discuss]

解题思路:题不难,但是改了好多次才ac的。

1.要注意输入的两个数不一定是i<j的,需要排序。

2.最后输出的i和j要跟刚开始输入的顺序一致,不能输出排序之后的。

#include <iostream>
#include <cstdio>

using namespace std;

int cal(int t){
    int countt=1;
    while(t!=1){
        countt++;
        if(t&1==1){
            t=3*t+1;
        }else{
            t/=2;
        }
    }
    return countt;
}

int main()
{
    int a,b;
    int maxx=0;
    int noww=0;
    while(~scanf("%d %d",&a,&b)){
        cout<<a<<' '<<b<<' ';
        if(a>b){
            a^=b;
            b^=a;
            a^=b;
        }
        maxx=0;
        for(int i=a;i<=b;i++){
            noww=cal(i);
            maxx=noww>maxx? noww:maxx;
        }
        cout<<maxx<<endl;
    }
    return 0;
}

 

posted @ 2018-06-01 10:52  多一份不为什么的坚持  阅读(179)  评论(0编辑  收藏  举报