nyoj113_字符串替换

字符串替换

时间限制:3000 ms  |  内存限制:65535 KB
难度:2
 
描述
编写一个程序实现将字符串中的所有"you"替换成"we"
 
输入
输入包含多行数据 

每行数据是一个字符串,长度不超过1000 
数据以EOF结束
输出
对于输入的每一行,输出替换后的字符串
样例输入
you are what you do
样例输出
we are what we do
来源
水题比赛
上传者
hzyqazasdf

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int main(){
    char a[1005];
    while(gets(a)){
        int len=strlen(a);
        int i;
        for(i=0;i<len-2;i++){
            if(a[i]=='y'&&a[i+1]=='o'&&a[i+2]=='u'){
                a[i]='w';
                a[i+1]='e';
                a[i+2]='*';
            }
        }
        for(i=0;i<len;i++){
            if(a[i]!='*'){
                printf("%c",a[i]);
            }
        }
        printf("\n");
    }
    return 0;
}

 

posted @ 2016-09-14 17:56  多一份不为什么的坚持  阅读(187)  评论(0编辑  收藏  举报