PAT甲级1151(由前序和中序确定LCA)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

前序和中序的解释:https://blog.csdn.net/ailunlee/article/details/80755357
代码:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
#include<cmath>


const int maxn=1e5+5;
typedef long long ll;
using namespace std;

map<int,int>pos;
int in[maxn],pre[maxn];
void LCA(int l,int r,int preroot,int a,int b)
{
    if(l>r)
    {
        return;
    }
     int Root=pos[pre[preroot]];
     int ina=pos[a];
     int inb=pos[b];
     if(ina<Root&&inb<Root)
     {
         LCA(l,Root-1,preroot+1,a,b);
     }
     else if(ina>Root&&inb>Root)
     {
         LCA(Root+1,r,preroot+Root-l+1,a,b);
     }
    else if ((ina < Root && inb> Root) || (ina > Root && inb < Root))
    {    
         printf("LCA of %d and %d is %d.\n", a, b, in[Root]);
         return ;
    }
    else if (ina == Root)
    {
         printf("%d is an ancestor of %d.\n", a, b);
         return ;
    }
    else if (inb == Root)
    {
         printf("%d is an ancestor of %d.\n", b, a);
         return ;
    }
}

int main()
{
    int m,n;
    cin>>m>>n;
    for(int t=1;t<=n;t++)
    {
        scanf("%d",&in[t]);
        pos[in[t]]=t;
    }
    for(int t=1;t<=n;t++)
    {
        scanf("%d",&pre[t]);
    }
    int a,b;
    while(m--)
    {
         scanf("%d%d",&a,&b);
         if(pos[a]==0&&pos[b]==0)
         {
            printf("ERROR: %d and %d are not found.\n",a,b);
         }
         else if(pos[a]==0&&pos[b]!=0)
         {
             printf("ERROR: %d is not found.\n",a);
         }
         else if(pos[a]!=0&&pos[b]==0)
         {
             printf("ERROR: %d is not found.\n",b);
         }
         else
         {
             LCA(1,n,1,a,b);
         }         
    }
    return 0;
}

 

posted @ 2019-08-16 09:28  black_hole6  阅读(546)  评论(0编辑  收藏  举报