HDU - 1019-Least Common Multiple(求最小公倍数(gcd))

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105. 
 

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer. 

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer. 

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output

105
10296

题解:

利用一个数与另一个数的乘积等于这两个数的最小公倍数×最大公约数

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

int main()
{
	int n,m;
	cin>>n;
	long long int k;
	for(int t=0;t<n;t++)
	{
		scanf("%d",&m);
		long long int cnt=1;
		for(int j=0;j<m;j++)
		{
			scanf("%d",&k);
			cnt=cnt*k/(__gcd(cnt,k));
		}
		printf("%lld\n",cnt);
	}
	return 0;
} 

 

posted @ 2018-12-06 14:48  black_hole6  阅读(125)  评论(0编辑  收藏  举报