MSSQL项目导入数据库:The server version or database compatibility level is not supported

阅文时长 | 0.39分钟 字数统计 | 626.4字符
主要内容 | 1、引言&背景 2、解决方案详细步骤 3、声明与参考资料
『MSSQL项目导入数据库:The server version or database compatibility level is not supported』
编写人 | SCscHero 编写时间 | 2021/8/26 PM6:5
文章类型 | 系列 完成度 | 已完成
座右铭 每一个伟大的事业,都有一个微不足道的开始。

一、引言&背景   完成度:100%

a) 应对问题

博主用SQLServer2014实例的数据库逆向到一个空的SQLServer工程当中,没想到报了这样一个错。

The server version or database compatibility level is not supported.
不支持服务器版本或数据库兼容性级别

如图。

b) 涉及知识点

服务器版本、数据库兼容级别。

c) 解决思路

  1. 查看所需要导入的数据库实例的版本号及兼容性级别。传送门
  2. 将MSSQL项目的属性设置为与实例相同的目标框架。同时检查下兼容性级别是否为默认。没问题后保存。
  3. 关闭项目,重启项目,再次导入。(此步在博主的一台老电脑上必须要做,要不然即使项目目标框架与实例匹配,仍然报错。

二、解决方案详细步骤   完成度:100%

  1. 查看需要导入的SQLServer数据库的Server版本及兼容性级别。详细步骤见传送门
  2. 打开DB Project的属性页查看目标框架及兼容性级别。操作方式如图。
  1. 关闭项目后,再次启动项目导入。

三、声明与参考资料   完成度:100%

原创博文,未经许可请勿转载。

如有帮助,欢迎点赞、收藏、关注。如有问题,请评论留言!如需与博主联系的,直接博客私信SCscHero即可。

posted on 2021-08-28 12:28  SCscHero  阅读(224)  评论(0编辑  收藏  举报

导航