HDU 1060 Leftmost Digit【log10/求N^N的最高位数字是多少】

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19010    Accepted Submission(s): 7507


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

 

Output
For each test case, you should output the leftmost digit of N^N.
 

 

Sample Input
2 3 4
 

 

Sample Output
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 

 

Author
Ignatius.L
【分析】:
【代码】:
#include <bits/stdc++.h>
using namespace std;

typedef long long LL;
const int MOD = 7;
typedef vector<LL> vec;
typedef vector<vec> mat;

int main()
{
    int n,t,ans;
    double tmp;
    cin>>t;
    while(t--){
        cin>>n;
        tmp=n*log10(1.0*n);
        tmp=tmp-(__int64)tmp;
        ans=(int)(pow(10.0,tmp));
        printf("%d\n",ans);
    }
    return 0;
}
数论

 

posted @ 2018-01-25 15:45  Roni_i  阅读(265)  评论(0编辑  收藏  举报