“玲珑杯”ACM比赛 Round #1

Start Time:2016-08-20 13:00:00 End Time:2016-08-20 18:00:00 Refresh Time:2017-11-12 19:51:52 Public

A -- Absolute Defeat

Time Limit:2s Memory Limit:64MByte

Submissions:394Solved:119

DESCRIPTION

Eric has an array of integers a1,a2,...,ana1,a2,...,an. Every time, he can choose a contiguous subsequence of length kk and increase every integer in the contiguous subsequence by 11.

He wants the minimum value of the array is at least mm. Help him find the minimum number of operations needed.

INPUT
There are multiple test cases. The first line of input contains an integer TT, indicating the number of test cases. For each test case: The first line contains three integers nn, mm and kk (1n105,1kn,1m104)(1≤n≤105,1≤k≤n,1≤m≤104). The second line contains nn integers a1,a2,...,ana1,a2,...,an (1ai104)(1≤ai≤104).
 
OUTPUT
For each test case, output an integer denoting the minimum number of operations needed.
 
SAMPLE INPUT
3
2 2 2
1 1
5 1 4
1 2 3 4 5
4 10 3
1 2 3 4
SAMPLE OUTPUT
1
0
15
SOLUTION
 
【题意】:给你一个长度为n的序列,每次你只能选择连续的k个数字加1,问你要进行多少次操作才能使所有的a[i]都大于m。 
【分析】:直接枚举,看每个数是否>m,否的话给从它开始的k个数,每个数都加上m-a[i]。
【代码】:
#include <bits/stdc++.h>

using namespace std;
int a[1000000+10];
int main()
{
    int t,n,m,k;
    cin>>t;
    while(t--)
    {
        cin>>n>>m>>k;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
        }
        int ans=0;
        int tmp;
        for(int i=0;i<n;i++)
        {
            if(a[i]<m)
            {
                tmp=m-a[i];
                ans+=tmp;
                for(int j=i;j<i+k;j++) //连续长度k内元素都加上差值
                {
                    a[j]+=tmp;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
View Code

 

posted @ 2017-11-12 19:53  Roni_i  阅读(138)  评论(0编辑  收藏  举报