ACM-ICPC 2018 焦作赛区网络预赛 A. Magic Mirror

Every morning she will ask the mirror: 'Mirror mirror tell me, who is the most beautiful girl in the world?' If the mirror says her name, she will praise the mirror: 'Good guy!', but if the mirror says the name of another person, she will assail the mirror: 'Dare you say that again?'

Today Jessie asks the mirror the same question above, and you are given a series of mirror's answers. For each answer, please output Jessie's response. You can assume that the uppercase or lowercase letters appearing anywhere in the name will have no influence on the answer. For example, 'Jessie' and 'jessie' represent the same person.

Input

The first line contains an integer T(1 \le T \le 100)T(1≤T≤100), which is the number of test cases.

Each test case contains one line with a single-word name, which contains only English letters. The length of each name is no more than 1515.

Output

For each test case, output one line containing the answer.

样例输入复制

2
Jessie
Justin

样例输出复制

Good guy!
Dare you say that again?

题目来源

ACM-ICPC 2018 焦作赛区网络预赛

 

题目意思是,给你一个字符串,不区分大小写,如果等于“jessie”,就输出“Good guy!”,反之就输出“Dare you say that again?”

 

#include<iostream>
#include<cstring>
using namespace std;

int main()
{
	char a[100];
	int n,m,j,k,i,T;
	cin>>T;
	getchar();
	while (T--)
	{
		scanf("%s",a);
	int len=strlen(a);
	for (i=0;i<len;i++)
	{
		if (a[i]>='A'&&a[i]<='Z')
		a[i] = a[i]-'A'+'a';
	}
	if (strcmp(a,"jessie")==0)
		
		cout<<"Good guy!"<<endl;
		else
		cout<<"Dare you say that again?"<<endl;
	}
	
	
	return 0;
}

 

posted @ 2018-09-15 17:13  RomanticChopin  阅读(125)  评论(0编辑  收藏  举报
-->
Live2D