Tallest Cow

题目描述

FJ's N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.
FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.
For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

 

输入

Line 1: Four space-separated integers: N, I, H and R 
Lines 2..R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.

 

输出

Lines 1..N: Line i contains the maximum possible height of cow i.

 

样例输入

9 3 5 5
1 3
5 3
4 3
3 7
9 8

样例输出

5
4
5
3
4
4
5
5
5

分析:第二个数据有什么用!?其实就是差分序列嘛,要注意去重。

#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
#include <map>
#include <queue>
#define range(i,a,b) for(int i=a;i<=b;++i)
#define LL long long
#define rerange(i,a,b) for(int i=a;i>=b;--i)
#define fill(arr,tmp) memset(arr,tmp,sizeof(arr))
using namespace std;
int N,I,H,R,a[100005],ans;
map<pair<int,int>,bool>vis;
void swap(int &x,int &y){
    int tmp=x;
    x=y;
    y=tmp;
}
void init(){
    cin>>N>>I>>H>>R;
    range(i,1,R){
        int x,y;
        cin>>x>>y;
        if(x>y)swap(x,y);
        if(vis[make_pair(x,y)])continue;
        vis[make_pair(x,y)]=true;
        --a[x+1];
        ++a[y];
    }
}
void solve(){
    range(i,1,N){
        ans+=a[i];
        cout<<H+ans<<endl;
    }
}
int main() {
    init();
    solve();
    return 0;
}
View Code

 

posted @ 2018-07-16 15:31  RhythmLian  阅读(203)  评论(0编辑  收藏  举报