the selection cannot be run on any server错误解决方法

1.问题

导入war包后运行jsp 显示: 

  the selection cannot be run on any server

2.问题原因

Dynamic Web Module 的版本与server不匹配。Dynamic Web Module的版本可以通过右键项目名->properties->Project Facets进行查看,并且可以在此处选择Tomcat运行的版本。如果右侧选择的Tomcat不是你安装的Tomcat版本或者右侧无可选Tomcat那么就会导致此问题。

3.解决方法

1.如果是由于没有选对Tomcat服务器,那么只需要在右侧选择已安装好的服务器即可。

2.如果是由于右侧服务器不可选导致的问题,那么需要对jst.web版本号进行更改,具体过程如下:

  在eclipse的workplace中找到这个工程文件夹->.settings->org.eclipse.wst.common.project.facet.core.xml

  打开把jst.web的版本号4.0修改为3.0或更低,重启Eclipse就可以了

 

4.参考文章

【1】https://www.cnblogs.com/luiyuying/p/9068584.html

posted @ 2020-05-17 14:56  红心火柴  阅读(15041)  评论(1编辑  收藏  举报