poj2975 Nim 胜利的方案数

Nim
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5545   Accepted: 2597

Description

Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removing one or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n piles having k1k2, …, kn stones respectively; in such a position, there are k1 + k2 + … + kn possible moves. We write each ki in binary (base 2). Then, the Nim position is losing if and only if, among all the ki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if the xor of the ki’s is 0.

Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

 111
1011
1101

There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, suppose k3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move when k1 = 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

Input

The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤ n ≤ 1000. On the next line, there are n positive integers, 1 ≤ ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case with n = 0 and should not be processed.

Output

For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

Sample Input

3
7 11 13
2
1000000000 1000000000
0

Sample Output

3
0
/*
poj2975 Nim 胜利的方案数

nim游戏是异或和不为0的时候,是必胜的。
例:先手人员可以先拿一个,然后异或和为0,然后对手拿多少,你就拿多少。
从而达到必胜的。
1011     ------>      1010
1010     拿一个       1010

这个是求总共有多少种必胜的方法,开始想的是通过SG值来计算,但是数范围太大
结果还是从nim的原理上分析
如果我们从一个人那个取走一部分,从而使剩下的所有的异或和为0
那么取的 那一堆的数量    ta[i] > 剩下其它碓的异或和
所以可以依靠这个来判断胜利的方法数量。

hhh-2016-08-01 20:16:14
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <functional>
#include <vector>
#include <queue>
using namespace std;
#define lson  (i<<1)
#define rson  ((i<<1)|1)
typedef long long ll;
using namespace std;
const ll mod = 1e9 + 7;
const ll INF = 0x3f3f3f3f;
const int maxn = 1000100;

ll ta[maxn];

int main()
{
    int n ;
    while(scanf("%d",&n) != EOF && n)
    {
        ll ans = 0;
        int tans = 0;
        for(int i = 0;i < n;i++)
        {
            scanf("%I64d",&ta[i]);
            ans ^= ta[i];
        }
        for(int i = 0;i < n;i++)
        {
            if( (ans ^ ta[i]) < ta[i])
                tans ++;
        }
        printf("%d\n",tans);
    }
    return 0;
}

  





posted @ 2016-08-10 16:43  Przz  阅读(908)  评论(0编辑  收藏  举报