HDU 5670 Machine

Machine

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 290    Accepted Submission(s): 179

Problem Description
There is a machine with m(2m30) coloured bulbs and a button.When the button is pushed, the rightmost bulb changes.
For any changed bulb,
if it is red now it will be green;
if it is green now it will be blue;
if it is blue now it will be red and the bulb that on the left(if it exists) will change too.
Initally all the bulbs are red. What colour are the bulbs after the button be
pushed n(1n<2^63) times?
 
Input
There are multiple test cases. The first line of input contains an integer T(1T15) indicating the number of test cases. For each test case:
The only line contains two integers m(2m30) and n(1n<263) .
 
Output
For each test case, output the colour of m bulbs from left to right.
R indicates red. G indicates green. B indicates blue.
 
Sample Input
2
3 1
2 3
 
Sample Output
RRG
GR
 
Recommend
wange2014
 
题目大意:初始状态下所有的灯都是红色的,输出经过n次变换后的灯。 
思路:就是把这个数转为3进制数,0,1,2分别为红,绿,蓝。。。
#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
int j=0, i, T, m, a[200];
__int64 n;
cin>>T;
while(T--)
{
j=0;
scanf("%d%I64d", &m, &n);
while(n!=0)
{
        a[++j]=n%3;
        n=n/3;
}
while(m>j)
{
cout<<"R";
m--;
}
for(i=m;i>=1;i--)
if(a[i]==0)
printf("R");
else if(a[i]==1)
printf("G");
else
printf("B");
printf("\n");
}
        return 0;
}

 

posted on 2016-04-23 23:18  2855669158  阅读(80)  评论(0编辑  收藏  举报

导航