Centos7下安装Calibre

最近安装了minDoc,然后就想安装下Calibre以使用minDoc的导出功能。

关于Calibre的安装,网上大部分的介绍是从源码安装,但是我在尝试通过源码安装中遇到一些问题,没有成功。主要有2个问题,一是PyQt5的许可问题:

Error: This version of PyQt5 and the commercial version of Qt have incompatible licenses.
另外还有个问题一直没找到解决方法:
FileNotFoundError: [Errno 2] No such file or directory: 'xdg-icon-resource'
 
后来还是尝试使用二进制方式安装,参考
不过这个文章中提到的版本太旧了,已经没有对应的安装文件,可以通过
查看支持的版本,然后使用
wget -nv -O- https://download.calibre-ebook.com/linux-installer.sh | sudo sh /dev/stdin version=4.10.0
安装即可。

posted @ 2020-11-19 09:05  LeoGIS  阅读(1496)  评论(0编辑  收藏  举报