ubuntu安装qemu

ubuntu安装qemu

    ubtuntu编译安装qemu 5.2.0,apt-get安装的版本过于老旧。

    环境:ubuntu 18.04.

wget https://download.qemu.org/qemu-5.2.0.tar.xz  
tar xvJf qemu-5.2.0.tar.xz  
mkdir build && cd build  

../configure
makemake install  

    编译安装过程中,存在环境依赖未安装的问题,首先提示ninja未安装。

apt-get install ninja-build
ninja

    编译安装好ninja之后,../configure的时候出现类似下面这种报错:

Program cgcc found: NO
Library m found: YES
Library util found: YES
Run-time dependency appleframeworks found: NO (tried framework)
Found pkg-config: /usr/bin/pkg-config (0.29.1)
Run-time dependency pixman-1 found: NO (tried pkgconfig)

../meson.build:302:2: ERROR: Dependency "pixman-1" not found, tried pkgconfig

A full log can be found at /opt/qemu-5.2.0/build/meson-logs/meson-log.txt

ERROR: meson setup failed

    这时候需要安装需要安装pixman依赖。

apt-get install libmount-dev

    然后就大功告成。

 

 

 

  

posted @ 2021-04-17 01:39  Riv4ille  阅读(1039)  评论(0编辑  收藏  举报