poj2096Collecting Bugs(概率期望dp)

Collecting Bugs

Time Limit: 10000MS   Memory Limit: 64000K
Total Submissions: 5672   Accepted: 2805
Case Time Limit: 2000MS   Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

/*
假设dp[i][j]表示已经在j个子系统中发现i类bug时所用天数的期望,明显dp[n][s] = 0。
1、在新的子系统中发现新的bug,即dp[i+1][j+1]
3、在已经发现过bug的子系统中发现新的bug,即dp[i+1][j]
2、在新的子系统中发现已经发现过的bug,即dp[i][j+1]
4、在已经发现过bug的子系统中发现已经发现过的bug,即dp[i+1][j+1]
同样,不难得出上述四种情况对应的概率分别为:
p1 = (n-i)*(s-j) / (n*s),p2 = (n-i)*(j) / (n*s),
p3 = i*(s-j) / (n*s),p4 = i*j / (n*s)。
同样根据期望的定义
dp[i][j] = p1*dp[i+1][j+1] + p2*dp[i+1][j] + p3*dp[i][j+1] + p4*dp[i][j] + 1,
移项合并一下,dp[i][j] = (p1*dp[i+1][j+1] + p2*dp[i+1][j] + p3*dp[i][j+1] + 1) / (1-p4)。
这样一来,我们要求的答案就是dp[0][0]。
*/
#include <cstdio>
#include <cstring>

using namespace std;

const int MAXN = 1005;
double dp[MAXN][MAXN];
double p1,p2,p3,p4;

int main()
{
    int n,s;
    while(~scanf("%d%d", &n, &s))
    {
        memset(dp,0,sizeof(dp));
        for(int i=n; i>=0; --i)
          for(int j=s; j>=0; --j)
            {
                if(i==n && j==s) continue;
                p1 = 1.0*(n-i)*(s-j)/(n*s);
                p2 = 1.0*(n-i)*j/(n*s);
                p3 = 1.0*i*(s-j)/(n*s);
                p4 = 1.0*i*j/ (n*s);
                dp[i][j] = (p1*dp[i+1][j+1]+p2*dp[i+1][j]+p3*dp[i][j+1]+1)/(1-p4);
            }
        printf("%.4f\n",dp[0][0]);
    }
    return 0;
}

 

 
posted @ 2017-07-21 16:36  安月冷  阅读(160)  评论(0编辑  收藏  举报