bzoj1606[Usaco2008 Dec]Hay For Sale 购买干草(01背包)

1606: [Usaco2008 Dec]Hay For Sale 购买干草

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 1240  Solved: 920
[Submit][Status][Discuss]

Description

    约翰遭受了重大的损失:蟑螂吃掉了他所有的干草,留下一群饥饿的牛.他乘着容量为C(1≤C≤50000)个单位的马车,去顿因家买一些干草.  顿因有H(1≤H≤5000)包干草,每一包都有它的体积Vi(l≤Vi≤C).约翰只能整包购买,
他最多可以运回多少体积的干草呢?

Input

    第1行输入C和H,之后H行一行输入一个Vi.

Output

 
    最多的可买干草体积.

Sample Input

7 3 //总体积为7,用3个物品来背包
2
6
5


The wagon holds 7 volumetric units; three bales are offered for sale with
volumes of 2, 6, and 5 units, respectively.

Sample Output

7 //最大可以背出来的体积

HINT

 

Buying the two smaller bales fills the wagon.

//板子
#include<iostream>
#include<cstdio>
#include<cstring>

#define N 50007

using namespace std;
int f[N],n,v,ans,w[N];

int main()
{
    scanf("%d%d",&v,&n);
    for(int i=1;i<=n;i++) scanf("%d",&w[i]);
    for(int i=1;i<=n;i++)
      for(int j=v;j>=w[i];j--)
        f[j]=max(f[j],f[j-w[i]]+w[i]);
    printf("%d\n",f[v]);
    return 0;
} 

 

 
posted @ 2017-06-21 20:20  安月冷  阅读(138)  评论(0编辑  收藏  举报