poj2975 Nim(经典博弈)

Nim
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5866   Accepted: 2777

Description

Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removing one or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n piles having k1k2, …, kn stones respectively; in such a position, there are k1 + k2 + … + kn possible moves. We write each ki in binary (base 2). Then, the Nim position is losing if and only if, among all the ki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if the xor of the ki’s is 0.

Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

 111
1011
1101

There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, suppose k3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move when k1 = 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

Input

The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤ n ≤ 1000. On the next line, there are n positive integers, 1 ≤ ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case with n = 0 and should not be processed.

Output

For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

Sample Input

3
7 11 13
2
1000000000 1000000000
0

Sample Output

3
0



简单博弈,博弈论经典入门:
http://blog.csdn.net/fromatp/article/details/53819565
http://blog.csdn.net/logic_nut/article/details/4711489

/*
如果对自己必胜,则要求对方必输,而题目给出了必输的要求就是n堆石子全部异或xor得到XOR,
如果XOR为0,则此状态必输。而我们就是要在其中一堆石子中拿取一定量的石头,使得这个行动过后对手到达必输点。
我们可以选取其中一堆石头,减少它的数目后,使得总的异或变成0,而题目就变成了,
到底有那几堆石头可以通过拿取一定的石头使得总的异或变成0.
对于st[i],因为st[i]^st[i]=0。则XOR^st[i]=tmp,根据弋获性质tmp就是如果第i堆石头不加入异或时,其他石头总的异或值。
如果我们可以使得第i堆石头变成tmp,则全部石头的异或值就能够得到0.根据这个理由,只要st[i]>tmp,则第i堆石头可行。
取大于而不是大于等于,是因为每一局都需要取一颗或以上的石头。
*/

#include<iostream>
#include<cstdio>
#include<cstring>

#define N 1007

using namespace std;
int st[N],XOR;

int main()
{
    int n,ans;
    while(scanf("%d",&n)&&n)
    {
        for(int i=1;i<=n;i++)
          scanf("%d",&st[i]);
        XOR=0;ans=0;
        for(int i=1;i<=n;i++) XOR^=st[i];
        for(int i=1;i<=n;i++)
        {
            if((XOR^st[i])<st[i]) ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 



posted @ 2017-06-10 20:53  安月冷  阅读(179)  评论(0编辑  收藏  举报