HDU1043 Eight(八数码:逆向BFS打表+康托展开)题解

Eight

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28040    Accepted Submission(s): 7457
Special Judge

Problem Description
The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:
 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.
 

Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle

1 2 3
x 4 6
7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8
 

Output
You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
 

Sample Input
2 3 4 1 5 x 7 6 8
 
Sample Output
ullddrurdllurdruldr



思路:

预先打表,逆向BFS,用康托展开来记录当前序列(例如2 3 4 1 5 x 7 6表示为46100),用node[ i ].father指向它的父节点,node[ i ].step表示走向他父节点的方向(实际BFS中其实是相反的),所以最终我们只要在打完表后,在表中寻找当前序列是否存在;若存在则沿着父节点走到终点,若不存在,则unsolvable。

参照代码:双击666查看代码

看别人的题解用A*做的...慢慢去看... 

第一次做的没用康托展开,直接map然后凉了,代码附在最后orz


AC Code:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cctype>
#include<queue>
#include<cmath>
#include<map>
#include<iostream>
#include<algorithm>
#define INF 0x3f3f3f3f
#define N 1000005
using namespace std;
int fac[9],to[4][2]={0,1,0,-1,1,0,-1,0};
char step[4]={'l','r','u','d'};	 
struct node1{
	int father;	//指示父节点 
	char step;	//记录当前节点走向父节点的方向 
}node[370000];
struct node2{
	int aa[9];	//当前序列 
	int son;	//康托展开表示的位置 
	int n;	//9的坐标 
};

void set_fac(){	//计算阶乘 
	fac[0]=1;
	for(int i=1;i<9;i++){
		fac[i]=fac[i-1]*i;
	}
}
int cantor(int a[]){	//康托展开 
	int i,j,k,ans=0;
	for(i=0;i<=8;i++){
		k=0;
		for(j=i+1;j<=8;j++){
			if(a[i]>a[j]) k++;
		}
		ans+=fac[8-i]*k;
	}
	return ans;
}
void bfs(){
	int fx,fy;
	for(int i=0;i<370000;i++){
		node[i].father=-1;
	}
	queue<node2> q;
	node2 a,b;
	for(int i=0;i<9;i++){	//从终点开始逆向搜索 
		a.aa[i]=i+1;
	}
	a.son=369999;a.n=8;node[a.son].father=0;	//指向自己,表明终点 
	q.push(a);
	while(!q.empty()){
		a=q.front();
		q.pop();
		for(int i=0;i<4;i++){
			b=a;
			fx=b.n/3;fy=b.n%3;	//对9坐标从一维转二维 
			fx+=to[i][0];fy+=to[i][1];
			if(fx<0 || fy<0 || fx>2 || fy>2) continue;
			b.n=3*fx+fy;	//把行动后的9坐标从二维转一维  
			int temp=b.aa[b.n];b.aa[b.n]=b.aa[a.n];b.aa[a.n]=temp;
			b.son=cantor(b.aa);
			if(node[b.son].father==-1){	//说明这个排列是第一次出现,即最少步骤 
				node[b.son].father=a.son;
				node[b.son].step=step[i];	//为了后面直接输出,这里与实际走向相反 
				q.push(b);
			}
		}
	}
}

int main(){
	set_fac();
	bfs();
	char get[30];
	int que[9];
	while(gets(get)>0){
		int k=0;
		for(int i=0;get[i]!='\0';i++){
			if(get[i]>='1' && get[i]<='8'){
				que[k++]=get[i]-'0';
			}
			else if(get[i]=='x'){
				que[k++]=9;
			}
		}
		int s=cantor(que);
		if(node[s].father==-1) printf("unsolvable\n");
		else{
			while(node[s].father!=0){
				printf("%c",node[s].step);
				s=node[s].father;
			}
			printf("\n");
		}
	}
	return 0;
}



没用康托展开(Memory Limit Exceeded):

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<cctype>
#include<queue>
#include<math.h>
#include<map>
#include<iostream>
#include<algorithm>
#define INF 0x3f3f3f3f
#define N 1000005
using namespace std;
int to[4][2]={0,1,0,-1,1,0,-1,0};
char step[4]={'l','r','u','d'};
struct node{
	int x,y;
	string s;
	string steps;
};
map<string,string> maps;
void bfs(){
	int f1,f2;
	queue<node> q;
	maps.clear();
	node begin,a,b;
	begin.steps="",begin.x=2,begin.y=2,begin.s="12345678x";
	q.push(begin);
	while(!q.empty()){
		a=q.front();
		q.pop();
		for(int i=0;i<4;i++){
			b=a;
			b.x+=to[i][0];
			b.y+=to[i][1];
			b.steps+=step[i];
			if(b.x<0 || b.y<0 || b.x>2 || b.y>2) continue;
			f1=3*a.x+a.y;	//¶þάת»¯ÎªÒ»Î¬ 
			f2=3*b.x+b.y;
			b.s[f1]=a.s[f2];
			b.s[f2]=a.s[f1];
			if(maps.find(b.s)==maps.end()){
				maps[b.s]=b.steps;
				q.push(b);
			}
		}
	}
}

int main(){
	int i,j;
	char str[10];
	node f;
	bfs();
	for(i=0;i<9;i++){
		cin>>str[i];
		if(str[i]=='x'){
			f.x=i/3;
			f.y=i%3;
		}
		f.s+=str[i];
	}
	if(maps.find(str)==maps.end()) printf("unsolvable\n");
	else{
		string ans=maps[f.s];
		reverse(ans.begin(),ans.end());
		cout<<ans<<endl;
	}
	return 0;
}


posted @ 2018-03-05 11:53  KirinSB  阅读(291)  评论(0编辑  收藏  举报