BZOJ3417[Poi2013]Tales of seafaring——BFS

题目描述

Young Bytensson loves to hang out in the port tavern, where he often listens to the sea dogs telling their tales of seafaring. Initially, he believed them all, however incredible they sounded. Over time though, he became suspicious. He has decided to write a program that will verify if there may be any grain of truth in those tall stories. Bytensson reasoned that while he cannot tell if the sailors indeed weathered all those storms, he can at least find out if their travel itineraries make sense. This is a task for a programmer, which Bytensson, unfortunately, is not. Help him out!
There are   ports and   waterways connecting them in the waters frequented by the sailors Bytensson listened to. If there is a waterway between two ports, then sailing from one to the other is possible. Any waterway can be sailed in both directions.
Bytensson got to know K seafaring tales. Each tells of a sailor who began his journey in one port, sailed a number of waterways, and ended up in another port, which may have been the one he initially set sail from. The sailor in question may have sailed through the same waterway many times, each time in any direction. 

一个n点m边无向图,边权均为1,有k个询问

每次询问给出(s,t,d),要求回答是否存在一条从s到t的路径,长度为d

路径不必是简单路(可以自交)

输入

In the first line of the standard input, there are three integers, N,M and K (2<=N<=5000,1<=M<=5000,1<=K<=1000000) These denote, respectively: the number of ports in the waters frequented by the sailors who told Bytensson their stories, the number of waterways, and the number of tales.
The M lines that follow specify the waterways. A single waterway's description consists of a single line that contains two integers, a and b (1<=a,b<=N,a<>b) separated by a single space; these specify the numbers of ports at the two ends of this particular waterway.
The K lines that follow specify the tales that Bytensson has heard. A single tale's description consists of a single line with three integers, s,t  and d (1<=S,T<=N,1<=d<=1000000000) separated by single spaces. These indicate that the tale's protagonist set sail from port no. s, ended the journey in port no. t, and sailed exactly d times through various waterways.

输出

Your program should print exactly K lines to the standard output; the i-th of them should contain the word TAK (Polish for yes) if the journey described in the i-th tale (in input order) could have taken place. If it could not, then the line should contain the word NIE(Polish for no).

样例输入

8 7 4
1 2
2 3
3 4
5 6
6 7
7 8
8 5
2 3 1
1 4 1
5 5 8
1 8 10

样例输出

TAK
NIE
TAK
NIE

提示

 
 
因为不必是简单路径,所以可以走最短路到达终点后在最后一条边来回走。
但最后来回走一条路的路径长是偶数,因此要维护每个点的奇偶最短路。
因为询问次数较多,但点数比较小,离线以每个点为起点bfs求一下最短路即可。
注意询问的s和t可能相同,需要判一下这个点有没有出度。
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<cmath>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define ll long long
using namespace std;
int n,m,k;
int head[5002];
int to[100010];
int next[100010];
int f[5002][2];
int x,y;
vector<int>v[5002];
int ans[1000010];
struct node
{
    int s;
    int t;
    int d;
}a[1000010];
int tot;
queue< pair<int,int> >q;
void add(int x,int y)
{
    tot++;
    next[tot]=head[x];
    head[x]=tot;
    to[tot]=y;
}
int main()
{
    scanf("%d%d%d",&n,&m,&k);
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d",&x,&y);
        add(x,y);
        add(y,x);
    }
    for(int i=1;i<=k;i++)
    {
        scanf("%d%d%d",&a[i].s,&a[i].t,&a[i].d);
        v[a[i].s].push_back(i);
    }
    for(int i=1;i<=n;i++)
    {
        if(v[i].size())
        {
            memset(f,-1,sizeof(f));
            f[i][0]=0;
            q.push(make_pair(i,0));
            while(!q.empty())
            {
                int now=q.front().first;
                int dis=q.front().second;
                q.pop();
                for(int j=head[now];j;j=next[j])
                {
                    if(f[to[j]][dis^1]==-1)
                    {
                        f[to[j]][dis^1]=f[now][dis]+1;
                        q.push(make_pair(to[j],dis^1));
                    }
                }
            }
            int len=v[i].size();
            for(int j=0;j<len;j++)
            {
                if(f[a[v[i][j]].t][a[v[i][j]].d&1]!=-1&&f[a[v[i][j]].t][a[v[i][j]].d&1]<=a[v[i][j]].d&&head[i]!=0)
                {
                    ans[v[i][j]]=1;
                }
            }
        }
    }
    for(int i=1;i<=k;i++)
    {
        ans[i]==1?printf("TAK\n"):printf("NIE\n");
    }
}
posted @ 2018-09-17 08:56  The_Virtuoso  阅读(216)  评论(0编辑  收藏  举报