BZOJ2527[Poi2011]Meteors——整体二分+树状数组

题目描述

Byteotian Interstellar Union (BIU) has recently discovered a new planet in a nearby galaxy. The planet is unsuitable for colonisation due to strange meteor showers, which on the other hand make it an exceptionally interesting object of study.
The member states of BIU have already placed space stations close to the planet's orbit. The stations' goal is to take samples of the rocks flying by. The BIU Commission has partitioned the orbit into msectors, numbered from 1to m, where the sectors 1and mare adjacent. In each sector there is a single space station, belonging to one of the nmember states.
Each state has declared a number of meteor samples it intends to gather before the mission ends. Your task is to determine, for each state, when it can stop taking samples, based on the meter shower predictions for the years to come.
Byteotian Interstellar Union有N个成员国。现在它发现了一颗新的星球,这颗星球的轨道被分为M份(第M份和第1份相邻),第i份上有第Ai个国家的太空站。
这个星球经常会下陨石雨。BIU已经预测了接下来K场陨石雨的情况。
BIU的第i个成员国希望能够收集Pi单位的陨石样本。你的任务是判断对于每个国家,它需要在第几次陨石雨之后,才能收集足够的陨石。
输入:
第一行是两个数N,M。
第二行有M个数,第i个数Oi表示第i段轨道上有第Oi个国家的太空站。
第三行有N个数,第i个数Pi表示第i个国家希望收集的陨石数量。
第四行有一个数K,表示BIU预测了接下来的K场陨石雨。
接下来K行,每行有三个数Li,Ri,Ai,表示第K场陨石雨的发生地点在从Li顺时针到Ri的区间中(如果Li<=Ri,就是Li,Li+1,...,Ri,否则就是Ri,Ri+1,...,m-1,m,1,...,Li),向区间中的每个太空站提供Ai单位的陨石样本。
输出:
N行。第i行的数Wi表示第i个国家在第Wi波陨石雨之后能够收集到足够的陨石样本。如果到第K波结束后仍然收集不到,输出NIE。
数据范围:
数据范围: 1<=n,m,k<=3*10^5 1<=Pi<=10^9 1<=Ai<10^9

输入

The first line of the standard input gives two integers, n and m(1<=n,m<=3*10^5) separated by a single space, that denote, respectively, the number of BIU member states and the number of sectors the orbit has been partitioned into.
In the second line there are mintegers Oi(1<=Oi<=n) separated by single spaces, that denote the states owning stations in successive sectors.
In the third line there are nintegers Pi(1<=Pi<=10^9) separated by single spaces, that denote the numbers of meteor samples that the successive states intend to gather.
In the fourth line there is a single integer k(1<=k<=3*10^5) that denotes the number of meteor showers predictions. The following klines specify the (predicted) meteor showers chronologically. The i-th of these lines holds three integers Li, Ri, Ai(separated by single spaces), which denote that a meteor shower is expected in sectors Li,Li+1,…Ri (if Li<=Ri) or sectors Li,Li+1,…,m,1,…Ri (if Li>Ri), which should provide each station in those sectors with Aimeteor samples (1<=Ai<10^9).
In tests worth at least 20% of the points it additionally holds that .

输出

Your program should print nlines on the standard output. The i-th of them should contain a single integer Wi, denoting the number of shower after which the stations belonging to the i-th state are expected to gather at least Pi samples, or the word NIE (Polish for no) if that state is not expected to gather enough samples in the foreseeable future.

样例输入

3 5
1 3 2 1 3
10 5 7
3
4 2 4
1 3 1
3 5 2

样例输出

3
NIE
1
 
对于每个国家我们可以二分答案然后模拟陨石雨验证,但时间复杂度爆炸。
既然每场陨石雨会影响多个国家,那么我们可以整体二分,将所有国家一起二分答案。
整体二分时每次只加入第$[l,mid]$场的陨石雨,并对每个国家验证,如果满足$k$就将这个国家置于左区间,否则将$k$减掉这次查询答案放到右区间。
因为每次陨石雨是对一段区间修改,我们可以差分之后用树状数组维护,这样单次查询和修改的时间复杂度就都是$O(log_{m})$。总时间复杂度为$O(nlog_{k}log_{m})$
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<cmath>
#include<cstdio>
#include<vector>
#include<bitset>
#include<cstring>
#include<iostream>
#include<algorithm>
#define ll long long
using namespace std;
vector<int>q[300010];
int n,m,k,x;
ll v[300010];
int ans[300010];
int s[300010];
struct lty
{
    int l,r,val;
}a[300010];
int c[300010];
int b[300010];
int now;
void add(int x,int val)
{
    for(int i=x;i<=m;i+=i&-i)
    {
        v[i]+=1ll*val;
    }
}
ll ask(int x)
{
    ll res=0;
    for(int i=x;i;i-=i&-i)
    {
        res+=v[i];
    }
    return res;
}
void change(int id,int opt)
{
    if(a[id].l<=a[id].r)
    {
        add(a[id].l,opt*a[id].val);
        add(a[id].r+1,-1*opt*a[id].val);
    }
    else
    {
        add(1,opt*a[id].val);
        add(a[id].r+1,-1*opt*a[id].val);
        add(a[id].l,opt*a[id].val);
    }
}
void solve(int l,int r,int L,int R)
{
    if(L>R)
    {
        return ;
    }
    if(l==r)
    {
        for(int i=L;i<=R;i++)
        {
            ans[c[i]]=l;
        }
        return ;
    }
    int mid=(l+r)>>1;
    for(int i=l;i<=mid;i++)
    {
        change(i,1);
    }
    int ql=L,qr=R;
    for(int i=L;i<=R;i++)
    {
        ll res=0;
        int len=q[c[i]].size();
        for(int j=0;j<len;j++)
        {
            res+=ask(q[c[i]][j]);
            if(res>=s[c[i]])
            {
                break;
            }
        }
        if(res>=s[c[i]])
        {
            b[ql++]=c[i];
        }
        else
        {
            b[qr--]=c[i];
            s[c[i]]-=res;
        }
    }
    for(int i=L;i<=R;i++)
    {
        c[i]=b[i];
    }
    for(int i=l;i<=mid;i++)
    {
        change(i,-1);
    }
    solve(l,mid,L,ql-1),solve(mid+1,r,ql,R);
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++)
    {
        scanf("%d",&x);
        q[x].push_back(i);
    }
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&s[i]);
        c[i]=i;
    }
    scanf("%d",&k);
    for(int i=1;i<=k;i++)
    {
        scanf("%d%d%d",&a[i].l,&a[i].r,&a[i].val);
    }
    solve(1,k+1,1,n);
    for(int i=1;i<=n;i++)
    {
        printf(ans[i]>k?"NIE\n":"%d\n",ans[i]);
    }
}

还有一种写法就是维护一个指针$now$表示当前加入了第$[1,now]$场的陨石雨,每次二分时移动$now$指针即可,但这样做的话被放在右区间的国家的$k$就不能减掉当次询问的答案了。

#include<set>
#include<map>
#include<queue>
#include<stack>
#include<cmath>
#include<cstdio>
#include<vector>
#include<bitset>
#include<cstring>
#include<iostream>
#include<algorithm>
#define ll long long
using namespace std;
vector<int>q[300010];
int n,m,k,x;
ll v[300010];
int ans[300010];
int s[300010];
struct lty
{
    int l,r,val;
}a[300010];
int c[300010];
int b[300010];
int now;
void add(int x,int val)
{
    for(int i=x;i<=m;i+=i&-i)
    {
        v[i]+=1ll*val;
    }
}
ll ask(int x)
{
    ll res=0;
    for(int i=x;i;i-=i&-i)
    {
        res+=v[i];
    }
    return res;
}
void change(int id,int opt)
{
    if(a[id].l<=a[id].r)
    {
        add(a[id].l,opt*a[id].val);
        add(a[id].r+1,-1*opt*a[id].val);
    }
    else
    {
        add(1,opt*a[id].val);
        add(a[id].r+1,-1*opt*a[id].val);
        add(a[id].l,opt*a[id].val);
    }
}
void solve(int l,int r,int L,int R)
{
    if(L>R)
    {
        return ;
    }
    if(l==r)
    {
        for(int i=L;i<=R;i++)
        {
            ans[c[i]]=l;
        }
        return ;
    }
    int mid=(l+r)>>1;
    while(now<mid)
    {
        now++;
        change(now,1);
    }
    while(now>mid)
    {
        change(now,-1);
        now--;
    }
    int ql=L,qr=R;
    for(int i=L;i<=R;i++)
    {
        ll res=0;
        int len=q[c[i]].size();
        for(int j=0;j<len;j++)
        {
            res+=ask(q[c[i]][j]);
            if(res>=s[c[i]])
            {
                break;
            }
        }
        if(res>=s[c[i]])
        {
            b[ql++]=c[i];
        }
        else
        {
            b[qr--]=c[i];
        }
    }
    for(int i=L;i<=R;i++)
    {
        c[i]=b[i];
    }
    solve(l,mid,L,ql-1),solve(mid+1,r,ql,R);
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++)
    {
        scanf("%d",&x);
        q[x].push_back(i);
    }
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&s[i]);
        c[i]=i;
    }
    scanf("%d",&k);
    for(int i=1;i<=k;i++)
    {
        scanf("%d%d%d",&a[i].l,&a[i].r,&a[i].val);
    }
    solve(1,k+1,1,n);
    for(int i=1;i<=n;i++)
    {
        printf(ans[i]>k?"NIE\n":"%d\n",ans[i]);
    }
}
posted @ 2019-04-11 21:57  The_Virtuoso  阅读(173)  评论(0编辑  收藏  举报