Ubuntu 安装 git 出现依赖错误

问题

报错如下:

正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
您也许需要运行“apt --fix-broken install”来修正上面的错误。
下列软件包有未满足的依赖关系:
 git : 依赖: liberror-perl 但是它将不会被安装
       依赖: git-man (> 1:2.7.4) 但是它将不会被安装
       依赖: git-man (< 1:2.7.4-.) 但是它将不会被安装
 libgdal1i : 依赖: libpng12-0 (>= 1.2.13-4) 但是它将不会被安装
 libpoppler58 : 依赖: libpng12-0 (>= 1.2.13-4) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt --fix-broken install”(也可以指定一个解决办法)。

按照网上说的运行apt-get update和apt-get upgrade 无效

单独安装liberror-perl

sudo apt install -f perl-base=5.22.1-9

依旧报依赖错误:

正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
您也许需要运行“apt --fix-broken install”来修正上面的错误。
下列软件包有未满足的依赖关系:
 libcairo-gobject-perl : 依赖: perlapi-5.30.0
 libcairo-perl : 依赖: perlapi-5.30.0
 libfile-fcntllock-perl : 依赖: perlapi-5.30.0
 libgdal1i : 依赖: libpng12-0 (>= 1.2.13-4) 但是它将不会被安装
 libglib-object-introspection-perl : 依赖: perlapi-5.30.0
 libglib-perl : 依赖: perlapi-5.30.0
 libhtml-parser-perl : 依赖: perlapi-5.30.0
 liblocale-gettext-perl : 预依赖: perl-base (>= 5.30.0-8) 但是 5.22.1-9 正要被安装
                          预依赖: perlapi-5.30.0
 libnet-dbus-perl : 依赖: perlapi-5.30.0
 libnet-ssleay-perl : 依赖: perlapi-5.30.0
 libpoppler58 : 依赖: libpng12-0 (>= 1.2.13-4) 但是它将不会被安装
 libtext-charwidth-perl : 依赖: perl-base (>= 5.30.0-8) 但是 5.22.1-9 正要被安装
                          依赖: perlapi-5.30.0
 libtext-iconv-perl : 依赖: perl-base (>= 5.30.0-8) 但是 5.22.1-9 正要被安装
                      依赖: perlapi-5.30.0
 libxml-parser-perl : 依赖: perlapi-5.30.0
 perl : 依赖: perl-base (= 5.30.0-9ubuntu0.2) 但是 5.22.1-9 正要被安装
 perl-modules-5.30 : 依赖: perl-base (>= 5.30.0-1) 但是 5.22.1-9 正要被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt --fix-broken install”(也可以指定一个解决办法)。

运行命令:

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade

报错:

忽略:1 http://cz.archive.ubuntu.com/ubuntu trusty InRelease
命中:2 http://cz.archive.ubuntu.com/ubuntu trusty Release
命中:4 http://mirrors.163.com/ubuntu xenial InRelease
命中:5 http://mirrors.163.com/ubuntu xenial-security InRelease
命中:6 http://mirrors.163.com/ubuntu xenial-updates InRelease
命中:7 http://mirrors.163.com/ubuntu xenial-proposed InRelease
命中:8 http://mirrors.163.com/ubuntu xenial-backports InRelease
正在读取软件包列表... 完成
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
您也许需要运行“apt --fix-broken install”来修正上面的错误。
下列软件包有未满足的依赖关系:
 libgdal1i : 依赖: libpng12-0 (>= 1.2.13-4) 但是它还没有被安装
 libpoppler58 : 依赖: libpng12-0 (>= 1.2.13-4) 但是它还没有被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt --fix-broken install”(也可以指定一个解决办法)。

有效解决方案:

安装libpng12-0

sudo add-apt-repository ppa:linuxuprising/libpng12
sudo apt update
sudo apt install libpng12-0

然后升级,这回成功了:

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade

然后安装liberror-perl ,成功

sudo apt install -f perl-base=5.22.1-9

最后git

sudo apt install -f git
posted @ 2023-05-29 11:15  fengyujia  阅读(996)  评论(0编辑  收藏  举报