代码改变世界

ERROR:当前的信任级别不允许使用“compilerOptions”属性

2007-10-18 05:09  晓风残月  阅读(...)  评论(...编辑  收藏
将原来基于 VS 05 的 AjaxControlToolkit 升级到 VS 08 beta 2,利用其  multi-targeting 依然选择 .NET 2.0,编译正常通过,出现了错误:
The current trust level does not allow use of the 'compilerOptions' attribute.
(当前的信任级别不允许使用“compilerOptions”属性。

最简单的方法是:修改 web.config 的 trust level 为 Full
  <system.web>
    
<!--<trust level="Medium"/>-->
    
<trust level="Full"/>
    
<pages>
      
<controls>
关于此参考:在 ASP.NET 中配置代码访问安全性

关于VS 05 升级到 08 中相关主题:Medium Trust and Visual Studio codename 'Orcas' Beta 2