PAT (Basic Level) Practice (中文) 1079 延迟的回文数 (20分) (大数加法)

1.题目

给定一个 k+1 位的正整数 N,写成 a​k​​⋯a​1​​a​0​​ 的形式,其中对所有 i 有 0≤a​i​​<10 且 a​k​​>0。N 被称为一个回文数,当且仅当对所有 i 有 a​i​​=a​k−i​​。零也被定义为一个回文数。

非回文数也可以通过一系列操作变出回文数。首先将该数字逆转,再将逆转数与该数相加,如果和还不是一个回文数,就重复这个逆转再相加的操作,直到一个回文数出现。如果一个非回文数可以变出回文数,就称这个数为延迟的回文数。(定义翻译自 https://en.wikipedia.org/wiki/Palindromic_number )

给定任意一个正整数,本题要求你找到其变出的那个回文数。

输入格式:

输入在一行中给出一个不超过1000位的正整数。

输出格式:

对给定的整数,一行一行输出其变出回文数的过程。每行格式如下

A + B = C

其中 A 是原始的数字,B 是 A 的逆转数,C 是它们的和。A 从输入的整数开始。重复操作直到 C 在 10 步以内变成回文数,这时在一行中输出 C is a palindromic number.;或者如果 10 步都没能得到回文数,最后就在一行中输出 Not found in 10 iterations.

输入样例 1:

97152

输出样例 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

输入样例 2:

196

输出样例 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

2.代码

(开始没注意到大数加法就用了string,后来改的时候就两个一起用懒得重写了)

#include<iostream>
#include<string>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
	string num;
	cin >> num;
	string answer,reanswer;
	int count = 10;
	reanswer.assign(num.rbegin(), num.rend());
	if (num == reanswer)
	{
		printf("%s is a palindromic number.\n", num.c_str());
		return 0;
	}

	while (count--)
	{
		int add = 0; char c;
		for (int i = 0,j=num.length()-1; i <num.length(); i++,j--)
		{
			c = (((num[i] - 48) + (num[j] - 48) + add) % 10) + '0';
			add = ((num[i] - 48) + (num[j] - 48)+add) / 10;
			answer.push_back(c);
		}
		if (add > 0)answer.push_back(add + '0');
		reverse(answer.begin(), answer.end());
		printf("%s", num.c_str());
		reverse(num.begin(), num.end());
		printf(" + %s = %s\n", num.c_str(), answer.c_str());
		reanswer.assign(answer.rbegin(), answer.rend());
		if (answer == reanswer)
		{
			printf("%s is a palindromic number.\n", answer.c_str()); break;
		}
		num = answer; answer = "";
	}
	if (count == -1)printf("Not found in 10 iterations.\n");

}

 

posted @ 2020-03-08 15:41  Jason66661010  阅读(94)  评论(0编辑  收藏  举报