PAT (Advanced Level) Practice 1107 Social Clusters (30分) (并查集)

1.题目

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

2.题目分析

mark用来标记有这个hobby的people,如果之前没有人有这个hobby就将这个人的ID赋给hobby,如果有的话就使用unions合并。(使用路径压缩+按秩分类)

boss存放所有的祖先节点,out存放个数

3.代码

#include<iostream>
#include<unordered_set>
#include<vector>
#include<functional>
#include<algorithm>
using namespace std;
int father[1002];
int ranks[1002];
int mark[1002];
bool cmp(int &a, int &b)
	{
		return a > b;
}
int find(int x)
{
	if (father[x] == x)return x;
	return father[x] = find(father[x]);
}
void unions(int x,int y)
{
	int a = find(x);
	int b = find(y);
	if (a == b)return;
	if (ranks[a] < ranks[b])father[b] = a;
	else
	{
		father[a] = b;
		if (ranks[a] > ranks[b])ranks[b]++;
	}


}
int main()
{
	int n,k,a;
	scanf("%d",&n);
	for (int i = 1; i <= n; i++)
		father[i] = i;
	for (int i = 1; i <=n; i++)
	{
		scanf("%d", &k);
		getchar();
		for (int j = 0; j < k; j++)
		{
			scanf("%d", &a);
			if (mark[a] == 0)mark[a] = i;
			else
				unions(mark[a], i);
		}
	}
	unordered_set<int>boss;
	for (int i = 1; i <= n; i++)
		if (i== find(i))
			boss.insert(i);
	printf("%d\n", boss.size());
	vector<int>out;
	for (auto it = boss.begin(); it != boss.end(); it++)
	{
		int count = 0;
		for (int j = 1; j <= n; j++)
			if (father[j] == *it)
//这里之所以能用father而不用find(),
//是因为上面if (i== find(i))已经将所有的节点进行了更新,
//所有此时所有的节点的father中存放的都是自己最顶层的祖先节点
				count++;
		out.push_back(count);
	}
	sort(out.begin(), out.end(), cmp);
	for (auto it2 = out.begin(); it2 != out.end(); it2++)
	{
		printf("%s%d", it2 == out.begin() ? "" : " ", *it2);
	}
}

 

posted @ 2020-04-09 20:54  Jason66661010  阅读(142)  评论(0编辑  收藏  举报