HDOJ(HDU) 3949 XOR

 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3525    Accepted Submission(s): 1212


Problem Description
XOR is a kind of bit operator, we define that as follow: for two binary base number A and B, let C=A XOR B, then for each bit of C, we can get its value by check the digit of corresponding position in A and B. And for each digit, 1 XOR 1 = 0, 1 XOR 0 = 1, 0 XOR 1 = 1, 0 XOR 0 = 0. And we simply write this operator as ^, like 3 ^ 1 = 2,4 ^ 3 = 7. XOR is an amazing operator and this is a question about XOR. We can choose several numbers and do XOR operatorion to them one by one, then we get another number. For example, if we choose 2,3 and 4, we can get 2^3^4=5. Now, you are given N numbers, and you can choose some of them(even a single number) to do XOR on them, and you can get many different numbers. Now I want you tell me which number is the K-th smallest number among them.
 

 

Input
First line of the input is a single integer T(T<=30), indicates there are T test cases.
For each test case, the first line is an integer N(1<=N<=10000), the number of numbers below. The second line contains N integers (each number is between 1 and 10^18). The third line is a number Q(1<=Q<=10000), the number of queries. The fourth line contains Q numbers(each number is between 1 and 10^18) K1,K2,......KQ.
 

 

Output
For each test case,first output Case #C: in a single line,C means the number of the test case which is from 1 to T. Then for each query, you should output a single line contains the Ki-th smallest number in them, if there are less than Ki different numbers, output -1.
 

 

Sample Input
2
2
1 2
4
1 2 3 4
3
1 2 3
5
1 2 3 4 5
 

 

Sample Output
Case #1:
1
2
3
-1
Case #2:
0
1
2
3
-1
Hint
If you choose a single number, the result you get is the number you choose.Using long long instead of int because of the result may exceed 2^31-1.
 
很模板的线性基求第k小。
只需要记录线性基中元素的个数,插入完了再改造一下线性基使得任意两位不相关。
如果线性基的元素个数<总的数的个数那么就可以异或出0.
 
code:
#include<iostream>
#include<cstdio>
#include<cstring>
#define ll long long
using namespace std;
ll ci[66],n,T,now,q;
struct xxj{
    ll a[66],siz;
    ll p[66],len;
    
    void clear(){
        memset(a,0,sizeof(a));
        memset(p,0,sizeof(p));
        len=siz=0;
    }
    
    void ins(ll x){
        for(int i=60;i>=0;i--) if(x&ci[i]){
            if(!a[i]){
                a[i]=x;
                siz++;
                break;
            }
            x^=a[i];
        }
    }
    
    void update(){
        for(int i=60;i>=0;i--) if(a[i])
            for(int j=i-1;j>=0;j--) if(a[i]&ci[j]) a[i]^=a[j];
        for(int i=0;i<=60;i++) if(a[i]) p[len++]=a[i];
    }
    
    ll kth(ll k){
        if(k>=ci[len]) return -1;
        ll ans=0;
        for(int i=0;i<len;i++) if(k&ci[i]) ans^=p[i];
        return ans;
    }
    
}mine;

int main(){
    ci[0]=1;
    for(int i=1;i<=60;i++) ci[i]=ci[i-1]+ci[i-1];
    
    scanf("%lld",&T);
    for(int l=1;l<=T;l++){
        printf("Case #%d:\n",l);
        
        mine.clear();
        scanf("%lld",&n);
        for(int i=1;i<=n;i++){
            scanf("%lld",&now);
            mine.ins(now);
        }
        
        mine.update();
        
        scanf("%lld",&q);
        while(q--){
            scanf("%lld",&now);
            if(mine.siz<n) now--;
            printf("%lld\n",mine.kth(now));
        }
    }
    
    return 0;
}

 

posted @ 2018-01-07 10:37  蒟蒻JHY  阅读(309)  评论(0编辑  收藏  举报