POJ:3320-Jessica's Reading Problem(尺取法)

Jessica’s Reading Problem

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15224 Accepted: 5241

Description

Jessica’s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica’s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica’s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2


解题心得:

  1. 就是给你n个可能重复的数,要你选择选择一段最小的区间要包含所有的数,问这个最小的区间有多长。
  2. 其实就是一个尺取法啊,考验了一点点技巧,关于这段区间内有多少个数,可以使用map映射,在map中从0变1数量+1,从1变0数量-1,这个数列一共有多少个数可以使用set来区分。

#include <algorithm>
#include <stdio.h>
#include <map>
#include <set>
using namespace std;
const int maxn = 1e6+100;

int num[maxn],n;
set <int> se;
map <int,int> maps;

void init() {
    scanf("%d",&n);
    for(int i=0;i<n;i++) {
        scanf("%d",&num[i]);
        se.insert(num[i]);
    }
}

int main() {
    init();
    int sum = se.size();
    int cnt,l,r,ans = maxn;
    l = r = cnt = 0;
    while(1) {
        while(cnt < sum && r < n) {
            if(maps[num[r]] == 0)
                cnt++;
            maps[num[r]]++;
            r++;
        }
        if(cnt < sum)
            break;
        ans = min(ans,r-l);
        maps[num[l]]--;
        if(maps[num[l]] == 0)
            cnt--;
        l++;
    }
    printf("%d\n",ans);
}
posted @ 2018-04-25 20:26  GoldenFingers  阅读(109)  评论(0编辑  收藏  举报