poj 1258 Agri-Net (Prim)

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 65922   Accepted: 27292

Description

  Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

  The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

  For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

  4
  0 4 9 21
  4 0 8 17
  9 8 0 16
  21 17 16 0

Sample Output

  28
/**
    题目大意:
        告诉你任意一个点到其他n-1个点的距离;
        让你找一条长度最短的线,使所有点在一个连通区域内。
解题算法:
     prim算法 (用于求图的连通图里的 “最小生成树”, 使其权值之和最小) prim算法模板: #define NN 1005 #define my_max 0x3f3f3f3f int my_map [NN][NN], my_weight [NN], n; int prim () { int cnt = 0, pos = 1, my_book [n] = {0, 1}; for (int i = 1; i <= n; ++ i) { if (!my_book [i]) { my_weight [i] = my_map [pos][i]; } } for (int i = 1; i < n; ++ i) { int my_min = my_max; for (int j = 1; j <= n; ++ j) { if (!my_book [j] && my_min > my_weight [j]) { my_min = my_weight [j]; pos = j; } } cnt += my_min; my_book [pos] = 1; for (int j = 1; j <= n; ++ j) { if (!my_book [j] && my_weight [j] > my_map [pos][j]) { my_weight [j] = my_map [pos][j]; } } } return cnt; } *
*/

C/C++ 代码实现:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <cstdio>
#define my_max 0x3f3f3f3f

using namespace std;

int n, my_map [105][105], a, my_weight [105];

int prim ()
{
    int cnt = 0, pos = 1, my_book [105] = {0, 1};
    for (int i = 1; i <= n; ++ i)
    {
        if (!my_book [i])
        {
            my_weight [i] = my_map [1][i];
        }
    }
    for (int i = 1; i < n; ++ i)
    {
        int my_min = my_max;
        for (int j = 1; j <= n; ++ j)
        {
            if (!my_book [j] && my_min > my_weight [j])
            {
                my_min = my_weight [j];
                pos = j;
            }
        }
        cnt += my_min;
        my_book [pos] = 1;
        for (int j = 1; j <= n; ++ j)
        {
            if (!my_book [j] && my_weight [j] > my_map [pos][j])
            {
                my_weight [j] = my_map [pos][j];
            }
        }
    }
    return cnt ;
}

int main ()
{
    while (~scanf("%d", &n))
    {
        for (int i = 1; i <= n; ++ i)
        {
            for (int j = 1; j <= n; ++ j)
            {
                scanf ("%d", &a);
                my_map [i][j] = my_map [j][i] = a;

            }
        }
        printf ("%d\n", prim ());
    }
    return 0;
}

 

posted @ 2018-04-25 14:15  GetcharZp  阅读(141)  评论(0编辑  收藏  举报