poj 2777 Count Color

题目连接

http://poj.org/problem?id=2777  

Count Color

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

 First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

线段树+lazy标记。
我用0表示杂色,非0表示纯色,用color数组记录出现的颜色。
具体如下。

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<set>
using std::set;
using std::sort;
using std::pair;
using std::swap;
using std::queue;
using std::multiset;
#define pb(e) push_back(e)
#define sz(c) (int)(c).size()
#define mp(a, b) make_pair(a, b)
#define all(c) (c).begin(), (c).end()
#define iter(c) decltype((c).begin())
#define cls(arr, val) memset(arr, val, sizeof(arr))
#define cpresent(c, e) (find(all(c), (e)) != (c).end())
#define rep(i, n) for(int i = 0; i < (int)n; i++)
#define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
const int N = 100000;
const int INF = 0x3f3f3f3f;
typedef unsigned long long ull;
#define lc (root<<1)
#define rc (root<<1|1)
#define mid ((l + r)>>1)
bool color[40];
struct SegTree {
	struct Node { int c; }seg[N << 2];
	inline void push_down(int root) {
		if (seg[root].c > 0) {
			seg[lc].c = seg[rc].c = seg[root].c;
			seg[root].c = 0;
		}
	}
	inline void update(int root, int l, int r, int x, int y, int col) {
		if (x > r || y < l) return;
		if (x <= l && y >= r) {
			seg[root].c = col;
			return;
		}
		push_down(root);
		update(lc, l, mid, x, y, col);
		update(rc, mid + 1, r, x, y, col);
	}
	inline void built(int root, int l, int r) {
		seg[root].c = 1;
		if (l == r) return;
		built(lc, l, mid);
		built(rc, mid + 1, r);
	}
	inline void query(int root, int l, int r, int x, int y) {
		if (x > r || y < l) return;
		if (seg[root].c > 0) {
			color[seg[root].c] = true;
			return;
		}
		query(lc, l, mid, x, y);
		query(rc, mid + 1, r, x, y);
	}
}work;
int main() {
#ifdef LOCAL
	freopen("in.txt", "r", stdin);
	freopen("out.txt", "w+", stdout);
#endif
	char ch;
	int n, q, t, c, x, y;
	while (~scanf("%d %d %d", &n, &t, &q)) {
		work.built(1, 1, n);
		while (q--) {
			getchar();
			scanf("%c", &ch);
			if ('C' == ch) {
				scanf("%d %d %d", &x, &y, &c);
				work.update(1, 1, n, x, y, c);
			} else {
				scanf("%d %d", &x, &y);
				memset(color, false, sizeof(color));
				work.query(1, 1, n, x, y);
				int tot = 0;
				for (int i = 1; i < t + 2; i++) { if (color[i]) tot++; }
				printf("%d\n", tot);
			}
		}
	}
	return 0;
}
posted @ 2015-10-10 16:11  GadyPu  阅读(148)  评论(0编辑  收藏  举报