hdu 5444 Elven Postman

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5444  

Elven Postman

Description

Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

Input

First you are given an integer $T\ (T \leq 10)$ indicating the number of test cases.

For each test case, there is a number $n\ (n \leq 1000)$ on a line representing the number of rooms in this tree. n integers representing the sequence written at the root follow, respectively $a_1, . . . , a_n$ where $a_1, . . . , a_n ∈ \{1, . . . , n\}$.

On the next line, there is a number $q$ representing the number of mails to be sent. After that, there will be $q$ integers $x_1, . . . , x_q$ indicating the destination room number of each mail.

Output

For each query, output a sequence of move ($E$ or $W$) the postman needs to make to deliver the mail. For that $E$ means that the postman should move up the eastern branch and $W$ the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.

Sample Input

2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1

Sample Output

E

WE
EEEEE

直接用二叉树模拟即可。。

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<vector>
#include<set>
using std::set;
using std::sort;
using std::pair;
using std::swap;
using std::multiset;
#define pb(e) push_back(e)
#define sz(c) (int)(c).size()
#define mp(a, b) make_pair(a, b)
#define all(c) (c).begin(), (c).end()
#define iter(c) decltype((c).begin())
#define cls(arr, val) memset(arr, val, sizeof(arr))
#define cpresent(c, e) (find(all(c), (e)) != (c).end())
#define rep(i, n) for(int i = 0; i < (int)n; i++)
#define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
const int N = 1010;
const int INF = ~0u >> 1;
typedef unsigned long long ull;
struct Node {
	int v;
	Node *ch[2];
	inline void set(int dat, Node *p) {
		v = dat, ch[0] = ch[1] = p;
	}
};
struct BST {
	Node *root, *tail, *null, stack[N];
	inline void init() {
		tail = &stack[0];
		null = tail++;
		null->set(INF, NULL);
		root = null;
	}
	inline Node *newNode(int dat) {
		Node *p = tail++;
		p->set(dat, null);
		return p;
	}
	inline void insert(Node *&x, int dat) {
		if (x == null) { x = newNode(dat); return; }
		insert(x->ch[dat > x->v], dat);
	}
	inline void insert(int dat) {
		insert(root, dat);
	}
	inline void find(int dat) {
		Node *x = root;
		while (x->v != dat) {
			if (dat < x->v) {
				putchar('E');
				x = x->ch[0];
			} else {
				putchar('W');
				x = x->ch[1];
			}
		}
		putchar('\n');
	}
}go;
int main() {
#ifdef LOCAL
	freopen("in.txt", "r", stdin);
	freopen("out.txt", "w+", stdout);
#endif
	int t, n, v, q;
	scanf("%d", &t);
	while (t--) {
		go.init();
		scanf("%d", &n);
		rep(i, n) {
			scanf("%d", &v);
			go.insert(v);
		}
		scanf("%d", &q);
		while (q--) {
			scanf("%d", &v);
			go.find(v);
		}
	}
	return 0;
}
posted @ 2015-09-16 21:11  GadyPu  阅读(204)  评论(0编辑  收藏  举报