hdu 5427 A problem of sorting

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5427  

 A problem of sorting

Description

There are many people's name and birth in a list.Your task is to print the name from young to old.(There is no pair of two has the same age.)

Input

First line contains a single integer $T \leq 100$ which denotes the number of test cases.

For each test case, there is an positive integer $n\ (1 \leq n \leq 100)$ which denotes the number of people,and next $n$ lines,each line has a name and a birth's year(1900-2015) separated by one space.

The length of name is positive and not larger than 100.Notice name only contain letter(s),digit(s) and space(s).

Output

For each case, output $n$ lines.

Sample Input

2
1
FancyCoder 1996
2
FancyCoder 1996
xyz111 1997

Sample Output

FancyCoder
xyz111
FancyCoder

字符串简单题。。

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<set>
using std::set;
using std::sort;
using std::pair;
using std::swap;
using std::queue;
using std::multiset;
#define pb(e) push_back(e)
#define sz(c) (int)(c).size()
#define mp(a, b) make_pair(a, b)
#define all(c) (c).begin(), (c).end()
#define iter(c) decltype((c).begin())
#define cls(arr, val) memset(arr, val, sizeof(arr))
#define cpresent(c, e) (find(all(c), (e)) != (c).end())
#define rep(i, n) for(int i = 0; i < (int)n; i++)
#define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
const int N = 110;
const int INF = 0x3f3f3f3f;
typedef unsigned long long ull;
struct Node {
	int age;
	char name[N];
	inline bool operator<(const Node &x) const {
		return age > x.age;
	}
}A[N];
int main() {
#ifdef LOCAL
	freopen("in.txt", "r", stdin);
	freopen("out.txt", "w+", stdout);
#endif
	int t, n;
	char buf[200], digit[5];
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		getchar();
		rep(i, n) {
			gets(buf);
			int v, j = 0, len = strlen(buf);
			for (; j < 4; j++) digit[j] = buf[len - 4 + j];
			digit[j] = '\0'; v = atoi(digit);
			buf[len - 5] = '\0';
			A[i].age = v, strcpy(A[i].name, buf);
		}
		sort(A, A + n);
		rep(i, n) printf("%s\n", A[i].name);
	}
	return 0;
}
posted @ 2015-09-06 20:06  GadyPu  阅读(282)  评论(0编辑  收藏  举报