poj 3281 Dining

题目连接

http://poj.org/problem?id=3281

Dining

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: NF, and D 
Lines 2..N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

最大流,拆点构图。

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<map>
using std::min;
using std::sort;
using std::pair;
using std::swap;
using std::queue;
using std::vector;
using std::multimap;
#define pb(e) push_back(e)
#define sz(c) (int)(c).size()
#define mp(a, b) make_pair(a, b)
#define all(c) (c).begin(), (c).end()
#define iter(c) __typeof((c).begin())
#define cls(arr, val) memset(arr, val, sizeof(arr))
#define cpresent(c, e) (find(all(c), (e)) != (c).end())
#define rep(i, n) for(int i = 1; i <= (int)n; i++)
#define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
const int Max_N = 1100;
const int INF = 0x3f3f3f3f;
struct Ford_Fulkerson {
    struct edge { int to, cap, next, rev; }G[Max_N << 2];
    int  N, F, D, tot, head[Max_N];
    bool vis[Max_N], Food[Max_N][Max_N], Drink[Max_N][Max_N];
    inline void init(int n, int f, int d) {
        tot = 0;
        this->N = n, this->F = f, this->D =d;
        cls(head, -1), cls(Food, false), cls(Drink, false);
    }
    inline void add_edge(int u, int v, int cap = 1) {
        G[tot] = (edge){ v, cap, head[u], tot + 1 }; head[u] = tot++;
        G[tot] = (edge){ u,   0, head[v], tot - 1 }; head[v] = tot++;
    }
    inline void built() {
        int x, y, v;
        rep(i, N) {
            scanf("%d %d", &x, &y);
            while(x--) {
                scanf("%d", &v);
                Food[i][v] = true;
            }
            while(y--) {
                scanf("%d", &v);
                Drink[i][v] = true;
            }
        }
    }
    inline int dfs(int u, int t, int f) {
        if(u == t) return f;
        vis[u] = true;
        for(int i = head[u]; ~i; i = G[i].next) {
            edge &e = G[i];
            if(e.cap > 0 && !vis[e.to]) {
                int d = dfs(e.to, t, min(e.cap, f));
                if(d > 0) {
                    e.cap -= d;
                    G[e.rev].cap +=d;
                    return d;
                }
            }
        }
        return 0;
    }
    inline void max_flow(int s, int t) {
        int flow = 0;
        while(true) {
            cls(vis, false);
            int f = dfs(s, t, INF);
            if(!f) break;
            flow += f;
        }
        printf("%d\n", flow);
    }
    inline void solve() {
        int s = 1, t = s + F + 2 * N + D + 1;
        rep(i, F) {
            add_edge(s, s + i);
        }
        rep(i, D) {
            add_edge(s + F + 2 * N + i, t);
        }
        rep(i, N) {
            add_edge(s + F + i, s + F + N + i, 1);
            rep(j, F) {
                if(Food[i][j]) add_edge(s + j, s + F + i);
            }
            rep(j, D) {
                if(Drink[i][j]) add_edge(s + F + N + i, s + F + 2 * N + j);
            }
        }
        max_flow(s, t);
    }
}go;
int main() {
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w+", stdout);
#endif
    int n, f, d;
    while(~scanf("%d %d %d", &n, &f, &d)) {
        go.init(n ,f ,d);
        go.built();
        go.solve();
    }
    return 0;
}
posted @ 2015-08-31 17:06  GadyPu  阅读(127)  评论(0编辑  收藏  举报