Flutter 依赖的那些事儿

Flutter 里面有2种库一样的东西,

Package -creating a pure Dart component. like a new Widget.

这种是纯Dart,相当于你自己写的组件。

Plugin- exposing an android or ios API for developers.

这种为了调用Android/IOS的API写的插件。

你可以在这里搜索你想要的插件/组件(吐槽经常进不去).

比如我们搜索cupertino_icons(为啥搜索这个。因为默认项目里面默认就依赖了这个玩意)

version下面可以看到发布的版本。

 

 

找到你Flutter项目里面的

dependencies:
  flutter:
    sdk: flutter

  # The following adds the Cupertino Icons font to your application.
  # Use with the CupertinoIcons class for iOS style icons.
  cupertino_icons: ^0.1.2

默认的项目里面已经有一个组件了

cupertino_icons 后面^代表说是最新的(并没有卵用) 后面0.1.2是版本号

每次你加入一个依赖的时候。请运行下

第一次get,后面改了版本号用upgrade。

 

那么我们什么时候更新它们呢。。或者说我咋知道有没有最新的版本呢。。难道要一个一个的去看吗。。用惯了VS的我。真是不习惯啊。。

这里提供一种方式。我是看一个歪果仁写的

 cupertino_icons: any

运行Packages upgrade。any就代表任何能匹配你的Flutter项目的最新版本(flutter sdk有自己的版本)这样也能解决掉依赖的冲突

然后我们去找这个文件。

搜索到。可以看到最新能适配的版本是0.1.2

最后记得把any 再换回 cupertino_icons: ^0.1.2

问题?我们为什么不要直接用any呢?

在实际项目开发中,不确定的版本号可能带来应用崩溃,会给你的开发调试带来灾难。

请记住。千万不要直接用any!

 

posted @ 2018-09-19 11:10 法的空间 阅读(...) 评论(...) 编辑 收藏