[POJ3311]Hie with the Pie

题目描述 Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

输入描述 Input Description

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

输出描述 Output Description

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

样例输入 Sample Input

3

0 1 10 10

1 0 1 2

10 1 0 10

10 2 10 0

0

样例输出 Sample Output

8

数据范围及提示 Data Size & Hint

 

之前的一些废话:是时候准备会考了。。

题解:dp[S][i]表示当前已经到过了S集合的城市,现在在i位置的最优解。先Floyd求出任意两点间最短路方便转移,然后三层循环,第一层枚举子集,第二层枚举当前位置,第三层枚举该去哪里。

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<cmath>
#include<cstring>
using namespace std;
typedef long long LL;
typedef pair<int,int> PII;
#define mem(a,b) memset(a,b,sizeof(a))
inline int read()
{
    int x=0,f=1;char c=getchar();
    while(!isdigit(c)){if(c=='-')f=-1;c=getchar();}
    while(isdigit(c)){x=x*10+c-'0';c=getchar();}
    return x*f;
}
const int maxn=20;
int n,dis[maxn][maxn],dp[1<<maxn][maxn],all;
int main()
{
    while(scanf("%d",&n)!=EOF && n)
    {
        mem(dis,0);mem(dp,42);n++;
        for(int i=1;i<=n;i++)for(int j=1;j<=n;j++)dis[i][j]=read();
        for(int k=1;k<=n;k++)for(int i=1;i<=n;i++)for(int j=1;j<=n;j++)dis[i][j]=min(dis[i][j],dis[i][k]+dis[k][j]);
        dp[1][1]=0;all=1<<n;
        for(int i=1;i<all;i++)
            for(int j=1;j<=n;j++)
                if(i&(1<<(j-1)))
                    for(int k=1;k<=n;k++)dp[i|(1<<(k-1))][k]=min(dp[i|(1<<(k-1))][k],dp[i][j]+dis[j][k]);
        printf("%d\n",dp[all-1][1]);
    }
    return 0;
}
View Code

总结:

posted @ 2017-06-21 18:20  小飞淙的云端  阅读(187)  评论(0编辑  收藏  举报