练涛

1023 Have Fun with Numbers(20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

思路:这道题比较简单,难点在于不能使用常用的数据类型(超出范围),这里使用字符串模拟加法,另外,需要比较元素组成,可以用数组记录,这里我排序比较字符串 

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main() {
	string a, b, c;
	int up=0;
	cin >> a;
	for (int i = a.length() - 1; i >= 0; i--) {     //字符串模拟加法器
		b = to_string((a[i]-'0') * 2 % 10 + up)+b;
		up = (a[i]-'0') * 2 / 10;
	}
	if (up)    //补上进位
		b = to_string(up) + b;
	c = b;     
	sort(a.begin(), a.end());    //排序,若数字组成相同,排序后字符串也相同
	sort(b.begin(), b.end());
	if (a == b)
		cout << "Yes" << endl;
	else
		cout << "No" << endl;
	cout << c;
	return 0;
}

 

posted on 2018-08-30 20:32  氵丨  阅读(375)  评论(0编辑  收藏  举报