TOJ2811: Bessie's Weight Problem(完全背包)

传送门(<---可以点的)

描述

Bessie, like so many of her sisters, has put on a few too many pounds enjoying the delectable grass from Farmer John's pastures. FJ has put her on a strict diet of no more than H (5 <= H <= 45,000) kilograms of hay per day.

Bessie can eat only complete bales of hay; once she starts she can't stop. She has a complete list of the N (1 <= N <= 500) haybales available to her for this evening's dinner and, of course, wants to maximize the total hay she consumes. She can eat each supplied bale only once, naturally (though duplicate weight valuess might appear in the input list; each of them can be eaten one time).

Given the list of haybale weights W_i (1 <= W_i <= H), determine the maximum amount of hay Bessie can consume without exceeding her limit of H kilograms (remember: once she starts on a haybale, she eats it all).

输入

* Line 1: Two space-separated integers: H and N

* Lines 2..N+1: Line i+1 describes the weight of haybale i with a single integer: W_i

输出

* Line 1: A single integer that is the number of kilograms of hay that Bessie can consume without going over her limit.

样例输入

56 4
15
19
20
21

样例输出

56

提示

INPUT DETAILS:
Four haybales of weight 15, 19, 20, and 21. Bessie can eat as many as she wishes without exceeding the limit of 56 altogether.

OUTPUT DETAILS:
Bessie can eat three bales (15, 20, and 21) and run right up to the limit
of 56 kg.

 
题意:给定H和N,下面N行是每个物品的重量,求不超过H,最多可以到达的重量。完全背包的裸题
代码:
#include<bits/stdc++.h>
using namespace std;
int dp[450010];
int main(){
    int weight[600];
    int h,n;
    scanf("%d %d",&h,&n);
    for(int i = 1 ; i <= n ; i++)scanf("%d",&weight[i]);
    memset(dp,0,sizeof(dp));
    for(int i = 1 ; i <= n ;i++){
        for(int j = weight[i] ; j <= h ; j++){
            if(j >= weight[i]){
                dp[j] = max(dp[j],dp[j-weight[i]]+weight[i]);    
            }
        }
    }
    printf("%d\n",dp[h]);
    return 0;
}

posted on 2018-03-30 17:18  Esquecer  阅读(352)  评论(0编辑  收藏  举报

导航