AttributeError: module 'tensorflow_core._api.v2.nn' has no attribute 'rnn_cell' tensorflow版本兼容问题-解决

 

 该问题是在tfv2环境下跑了tfv1的代码导致的,只需把v1的用法替换成v2留出的兼容用法即可:

tf.compat.v1.nn.rnn_cell.RNNCell代替tf.nn.rnn_cell.RNNCell

参考:https://tensorflow.google.cn/api_docs/python/tf/compat/v1/nn/rnn_cell/RNNCell?hl=en

也可以这样,使2.0的环境能够运行1.0的代码:

import tensorflow.compat.v1 as tf

tf.disable_v2_behavior()

posted @ 2020-05-08 23:00  秋饮  阅读(...)  评论(...编辑  收藏