HDOJ 1501 Zipper 【DP】【DFS+剪枝】

HDOJ 1501 Zipper 【DP】【DFS+剪枝】

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10886 Accepted Submission(s): 3925

Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming “tcraete” from “cat” and “tree”:

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming “catrtee” from “cat” and “tree”:

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form “cttaree” from “cat” and “tree”.

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

题意
给出三个字符串 a, b, c 询问 字符串 C是不是由 字符串 A,B 顺序取出来组成的,也就是说,字符串C中取出两个子序列,会不会这两个子序列一个是A,一个是B 如果满足这个条件 是yes 反之 no

思路【DP】

假如字符串C的最后一个字符是字符串A 或者字符串B 的 那么 字符串C -1 的字符串 必然是由 字符串A -1 组成的字符串和字符串B 顺序取出 或者 是 字符串A 和字符串B - 1组成的字符串顺序取出,往前推就可以了

所以
DP[i][j] 分别表示 取字符串 A 的前 i 位,取字符串 B 的前 j 位
如果 DP[i - 1][j] == 1 && A[i - 1] == C[i + j - 1]
那么 DP[i][j] = 1
或者如果 DP[i][j - 1] == 1 && B[j - 1] == C[i + j - 1]
那么DP[i][j] = 1

AC代码

#include <bits/stdc++.h>  //DP
using namespace std;
const int maxn = 2 * 1e2 + 5;
int dp[maxn][maxn];
int main()
{
    int t;
    cin >> t;
    int i, j, k;
    for (k = 1; k <= t; k++)
    {
        string s[3];
        int len[3];
        for (i = 0; i < 3; i++)
        {
            cin >> s[i];
            len[i] = s[i].size();
        }    
        memset(dp, 0, sizeof(dp));
        for (i = 0; i < len[0]; i++)
        {
            if (s[0][i] == s[2][i])
                dp[i + 1][0] = 1;
            else
                break;
        }
        for (i = 0; i < len[1]; i++)
        {
            if (s[1][i] == s[2][i])
                dp[0][i + 1] = 1;
            else
                break;
        }
        for (i = 1; i <= len[0]; i++)
        {
            for (j = 1; j <= len[1]; j++)
            {
                if (dp[i - 1][j] && s[0][i - 1] == s[2][i + j - 1])
                    dp[i][j] = 1;
                if (dp[i][j - 1] && s[1][j - 1] == s[2][i + j - 1])
                    dp[i][j] = 1;
            }
        }
        printf("Data set %d: ", k);
        if (dp[len[0]][len[1]])
            cout << "yes\n";
        else
            cout << "no\n";
    }
}

思路【DFS】

如果 满足 a[x] == c[x + y]
那么我们就往 x + 1, y 去找
如果 满足 b[y] == c[x + y]
那么我们就往 x, y + 1 去找

AC代码

#include <bits/stdc++.h>    //DFS
using namespace std;
const int maxn = 2 * 1e2 + 5;
string a, b, c;
int len_a, len_b, len_c;
int ans;
int vis[maxn][maxn];
void dfs(int x, int y)
{
    if (x + y == len_c)
    {
        ans = 1;
        return ;
    }    
    if (vis[x][y])
        return ;
    if (a[x] == c[x + y])
    {
        vis[x][y] = 1;
        dfs(x + 1, y);
    }    
    if (b[y] == c[x + y])
    {
        vis[x][y] = 1;
        dfs(x, y + 1);
    }    
}
int main()
{
    int t;
    int k;
    cin >> t;
    for (k = 1; k <= t; k++)
    {
        cin >> a >> b >> c;
        len_a = a.size(), len_b = b.size(), len_c = c.size();
        printf("Data set %d: ", k);
        ans = 0;
        memset(vis, 0, sizeof(vis));
        dfs(0, 0);
        if (ans)
            cout << "yes\n";
        else
            cout << "no\n";
    }
}
posted @ 2018-03-04 10:13  Dup4  阅读(114)  评论(0编辑  收藏  举报