思科模拟器:如何用三层交换机实现不同VLAN间的通信

【实验原理】

在交换网络中,通过VLAN对一个物理网络进行了逻辑划分,不同的VLAN之间是无法直接访问的,必须通过三层的路由设备进行连接。一般利用路由器或三层交换机来实现不同VLAN间的相互访问。三层交换机和路由器具备网络层的功能,能够根据数据的IP包头信息,进行选路和转发,从而实现不同网段之间的访问。

直连路由是指:为三层设备的接口配置IP地址,并且激活该端口,三层设备会自动产生该接口IP所在网段的直连路由信息。

三层交换机实现VLAN互访的原理是,利用三层交换机的路由功能,通过识别数据包的IP地址,查找路由表进行选路转发。三层交换机利用直连路由可以实现不同VLAN之间的互相访问。三层交换机给接口配置IP地址,采用SVI(交换机虚拟接口)的方式实现VLAN间互连。SVI是指为交换机中的VLAN创建虚拟接口,并且配置IP地址。

【实验设备】

三层交换机1台,两层交换机1台,PC2台,交叉线1根,直通线2根。

    二层交换机                  三层交换机    

 

【连接示意图】

 

PC0:

 

 

PC1:

 

【实验步骤】

  1. 配置pc端,如上图
  2. 配置两层交换机
    1. 创建vlan                   

Switch>enable

Switch#configure terminal

Switch(config)#vlan 10

Switch(config-vlan)#exit

Switch(config)#vlan 20

Switch(config-vlan)#end

Switch#show vlan

2.端口 移动 到 vlan 下

Switch#configure terminal

Switch(config)#interface fastethernet 0/2

Switch(config-if)#switchport access vlan 10                                                                           

Switch(config-if)#exit

Switch(config)#interface fastethernet 0/3

Switch(config-if)#switchport access vlan 20

Switch(config-if)#end

Switch#show vlan


 

vlan情况:


 

3.与三层交换机设trunk链路

Switch(config)#interface fastethernet 0/1

Switch(config-if)#switchport mode trunk

 

3. 配置 三层 交换机

1.创建 vlan

Switch>enable

Switch#configure terminal

Switch(config)#vlan 10

Switch(config-vlan)#exit

Switch(config)#vlan 20

Switch(config-vlan)#end

Switch#show vlan


 

               vlan情况:


 

 

2.给vlan分配管理 ip

Switch#configure terminal

Switch(config)#interface vlan 10

Switch(config-if)#ip address 192.168.10.254 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#exit

Switch(config)#interface vlan 20

Switch(config-if)# ip address 192.168.20.254 255.255.255.0

Switch(config-if)#no shutdown

最后还有在Switch(config)  ip routing

这是启用三层交换机的功能,不启用则为二层交换机

 

3.三层交换机上设trunk链路

Switch(config)#interface fastethernet 0/1

Switch(config-if)#switchport mode trunk


 

 

最后实验一下pc0与pc1的连通性:

PC0 ping PC1:

 

 第一个数据包丢掉是因为第一次封装的的时候发现ARP缓存信息中没有目的的MAC地址,所以封装失败。于是发送ARP请求获得目的MAC,再次封装就成功发送ping包了。更详细的情况读者可以自行查阅相关书籍,本篇不做详细讲解。

                   

                     

 

posted @ 2019-05-02 20:55  Diligent_Memory  阅读(11175)  评论(0编辑  收藏  举报