HDU-1698 JUST A HOOK 线段树

最近刚学线段树,做了些经典题目来练手
Just a Hook
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24370 Accepted Submission(s): 12156

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
这里写图片描述
Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input
1
10
2
1 5 2
5 9 3

Sample Output
Case 1: The total value of the hook is 24.

题目大意:Dota中的屠夫,有一个钩子,钩子分为n段,现在给出m个指令,将【X,Y】段钩子变成Z种(Z分为三种:1为铜钩,2为银钩,3为金钩)初始钩子都为Cu,m次操作后,求整个钩的价值
每组样例有t组数据
(N<=100000,1<=X<=Y<=N,1<=Z<=3)

维护一棵线段树,区间修改,最后求一下全区间的和,唯一可以说的就是惰性标记是直接改变,并非不断累积
因为所求是全区间的和,所以没必要再额外写一个区间求和的函数,直接在修改时下放标记,最后输出这颗线段树的根即可

代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
#define maxlen 100001
int value[maxlen<<2]={0},delta[maxlen<<2]={0};
int dota[maxlen]={0};

void updata(int now)
{
    value[now]=value[now<<1]+value[now<<1|1];   
}

void build(int l,int r,int now)
{
    if (l==r)
        {
            value[now]=dota[l];
            return;
        }
    int mid=(l+r)>>1;
    build(l,mid,now<<1);
    build(mid+1,r,now<<1|1);
    updata(now);
}

void pushdown(int now,int ln,int rn)
{
    if (delta[now]!=0)
        {
            delta[now<<1]=delta[now];
            delta[now<<1|1]=delta[now];
            value[now<<1]=delta[now]*ln;
            value[now<<1|1]=delta[now]*rn;
            delta[now]=0;
        }   
}

void section_change(int L,int R,int l,int r,int now,int data)
{
    if (L<=l && R>=r)
        {
            value[now]=data*(r-l+1);
            delta[now]=data;
            return;
        }
    int mid=(l+r)>>1;
    pushdown(now,mid-l+1,r-mid);
    if (L<=mid)
        section_change(L,R,l,mid,now<<1,data);
    if (R>mid)
        section_change(L,R,mid+1,r,now<<1|1,data);
    updata(now);
}

int main()
{
    int t;
    int n;
    int m;
    int time=1;
    scanf("%d",&t);
    while (true)
        {
            if (t==0) break;
            scanf("%d",&n);
            for (int i=1; i<=n; i++)
                dota[i]=1;
            memset(delta,0,sizeof(delta));
            memset(value,0,sizeof(value));
            build(1,n,1);
            scanf("%d",&m);
            for (int i=1; i<=m; i++)
                {
                    int start,end,data;
                    scanf("%d%d%d",&start,&end,&data);
                    section_change(start,end,1,n,1,data);
                }
            printf("Case %d: The total value of the hook is %d.\n",time,value[1]);
            time++;
            t--;
        }
    return 0;
}
posted @ 2015-12-04 22:01  DaD3zZ  阅读(125)  评论(0编辑  收藏  举报