hdu 2795 Billboard (线段树)

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16413    Accepted Submission(s): 6956


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

 

Sample Input
3 5 5
2
4
3
3
3
 

 

Sample Output
1
2
1
3
-1

 

单点更新,区间求最值。查询时优先往左儿子,每次查询完同步更新结点。

 

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <algorithm>

using namespace std;

const int N  = 200005;
int num[N << 2];
int h, w, n;

void Build(int left, int right, int i){    //建树
    num[i] = w;
    if(left == right) return;
    int mid;
    mid = (left + right) / 2;
    Build(left, mid, i * 2);
    Build(mid + 1, right, i * 2 + 1);
}

void Max(int i){
    num[i] = max(num[i * 2], num[i * 2 + 1]);    //更新父亲节点
}

int Query(int wide, int left, int right, int i){    //区间查群最大值
    if(left == right){    //同步更新结点
        num[i] -= wide;
        return left;
    }
    int mid;
    mid = (left + right) / 2;
    int ret = (num[i * 2] >= wide) ? Query(wide, left, mid, i * 2) : Query(wide, mid + 1, right, i * 2 + 1);  //优先往左查
    Max(i);
    return ret;
}

int main(){
    while(~scanf("%d%d%d", &h, &w, &n)){
        if(h > n) h = n;
        Build(1, h, 1);
        while(n--){
            int wide;
            scanf("%d", &wide);
            if(num[1] < wide) printf("-1\n");
            else printf("%d\n", Query(wide, 1, h, 1));
        }
    }    
    return 0;
}
posted @ 2015-11-16 16:18  shadow_C  阅读(129)  评论(0编辑  收藏  举报