解决laravel Class 'Doctrine\DBAL\Driver\PDOMySql\Driver' not found 错误

这个错误的原因来自于没有安装一个依赖库:

官方文档说明如下:

Modifying Columns

Prerequisites

Before modifying a column, be sure to add the doctrine/dbal dependency to your composer.json file. The Doctrine DBAL library is used to determine the current state of the column and create the SQL queries needed to make the specified adjustments to the column:

composer require doctrine/dbal

使用上面提到的命令安装指定依赖就行了。

 

这个错误是我使用renamecolume修改列的名字的时候发现的。

posted @ 2019-03-17 12:01  ComputerPlayerJs  阅读(2252)  评论(0编辑  收藏  举报