ZOJ 3609 Modular Inverse



Modular Inverse

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input

33 114 125 13

Sample Output

4Not Exist8

References


Author: WU, Zejun
Contest: The 9th Zhejiang Provincial Collegiate Programming Contest


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main()
{
    int a,m;
    int T;
    cin>>T;
while(T--)
{
    cin>>a>>m; int i;
    for(i=1;i<=m;i++)
    {
        if((i*a-1)%m==0)
            break;
    }
    if(i==m+1)
        puts("Not Exist");
    else
        printf("%d\n",i);
}
    return 0;
}

posted @ 2013-08-02 07:17  码代码的猿猿  阅读(226)  评论(0编辑  收藏  举报